11

I search using the URL address bar in Firefox however when I search a phrase or whatever a popup always comes up asking " Did you mean to go to example? ". It's quite annoying and was wondering if it could be turned off. I don't use the other search bar because whenever I click on it or try to use it an ugly panel comes down with the engines I can search with. Even if I turn off all other search engines it still persists.

6 Answers 6

3

It seems we will be able disable this new feature via about:config in Firefox 36: https://bugzilla.mozilla.org/show_bug.cgi?id=1088050

For now you can add this line:

notification[value="keyword-uri-fixup"] { display: none !important; }

to the userChrome.css inside the chrome subfolder of your Firefox profile folder. If userChrome.css doesn't exist there, create it: http://kb.mozillazine.org/UserChrome-example.css

Or, alternatively, you can use the Stylish add-on and create a new user style like this:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
notification[value="keyword-uri-fixup"] { display: none !important; }
1
  • What about for Chrome/Chromium as I learned it also occurs in those browsers? Feb 23, 2015 at 7:00
2

This is probably due to your ISP providing you with a poorly-configured DNS server, as per this Super User answer about Chrome, which behaves similarly:

Your DNS is taking that word and telling Chrome that its a website. So Chrome asks you if you meant to visit it. Chances are, if you did visit that site, you'd end up on your ISP's not found page.

The only way I've found to rectify this is turning off the "web service" option in the options and changing your DNS to [a better DNS provider].

1

switch your DNS from the default provided by your ISP to Google DNS:

"The Google Public DNS IP addresses (IPv4) are as follows:

8.8.8.8

8.8.4.4"

https://developers.google.com/speed/public-dns/docs/using#setup

1
  • 1
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Jul 31, 2016 at 14:43
0

To remove the suggestions, go to Firefox Preferences and click on the Privacy tab.

Under the Location Bar setting at the bottom, select the Nothing option from the drop down menu to disable all suggestions.

1
  • I've already done that, it did nothing except take away the panel that tumbles down from the URL bar as you're typing. Jan 25, 2015 at 12:36
0

The answer in the Mozilla docs worked for me:

You can set browser.urlbar.unifiedcomplete to false to remove the Visit page suggestion from the location bar drop down list.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

0

The simplest way to solve this is to re-configure your computer's DNS settings to use a dedicated service rather than your ISP's default DNS. Depending on your setup, this may also have positive side-effects with regard to your internet speed, security, ad-blocking, etc.

On Windows 10:

  • Open the Control Panel.
  • Select "Network and Internet."
  • Select "Network and Sharing Center."
  • Under "View your active networks," click on the name of your network interface (for example, the name of your Wi-Fi network or "Ethernet" for a wired connection).
  • In the pop-up window, select "Properties."
  • Select "Internet Protocol Version 4" and then click "Properties" again in this new pop-up window.
  • Instead of "Obtain DNS server address automatically," select "Use the following DNS server addresses" and enter the IP address(es) belonging to your chosen DNS provider.
  • Also update "Internet Protocol Version 6" in the same manner.

Windows 10 DNS Settings


On Mac OS:

  • Open System Preferences.
  • Select "Network."
  • Select your internet network interface (Wi-Fi, Ethernet, etc.), and then click the "Advanced" button.
  • Under the DNS tab, use the "+" button to add the IP addresses belonging to your chosen DNS provider, the "-" button to remove existing ones, and drag-and-drop to adjust the order if necessary.
  • Click "OK" in the Advanced pop-up window and then "Apply" in the main Network settings panel.

Mac OS DNS Settings


For advanced users, it might be worth doing a bit of research to decide which provider is best for your needs. For everyone else, just use one of these.

Cloudflare:

  • Primary DNS (IPv4): 1.1.1.1
  • Secondary DNS (IPv4): 1.0.0.1
  • Primary DNS (IPv6): 2606:4700:4700::1111
  • Secondary DNS (IPv6): 2606:4700:4700::1001

Google DNS:

  • Primary DNS (IPv4): 8.8.8.8
  • Secondary DNS (IPv4): 8.8.4.4
  • Primary DNS (IPv6): 2001:4860:4860::8888
  • Secondary DNS (IPv6): 2001:4860:4860::8844

OpenDNS:

  • Primary DNS (IPv4): 208.67.222.222
  • Secondary DNS (IPv4): 208.67.220.220
  • Primary DNS (IPv6): 2620:119:35::35
  • Secondary DNS (IPv6): 2620:119:53::53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.