39

I never had this problem until today. When I watch a youtube video everything is fine, until I make the video fullscreen. It actually continues to play perfectly when fullscreen, but when I then exit fullscreen my sidebar and topbar are gone, and the screen is just frozen. Also my cursor is gone. It does seem to respond to ALT-F4, but it takes about 15 seconds to even close the window, and after that everything is unusable (basically frozen). What's strange though, when I re-enter fullscreen after exiting (and unity being frozen) the video plays perfectly still.

For now my workaround is opening tty1 and executing pkill -u username which logs off the user. I have looked at /var/log/syslog but it seems to be empty.

Is this freezing a common problem, if not, how can I make steps to fix this?


EDIT with specs:

I'm on a simple Samsung laptop with: Ubuntu 14.10 64-bit, Intel® Core™ i5-3210M, Intel® Ivybridge Mobile (So integrated intel hd graphics 4000), 8GB ram. I don't think i've ever changed my video drivers, but it's reported as i915. Ubuntu is up to date, and my browser is Chrome 40.0.2214.91 (64-bit). (Will test out now with firefox, but already posting this because my pc might freeze again)


EDIT 2: It doesn't freeze on Firefox. Will try reinstalling chrome now... EDIT 3: Reinstalling chrome didn't help. Will try chrome 32-bit too now...

  • What kind of hardware? Do you use proprieraty video driver? Ubuntu is up to date? What browser are you using? – diegov Jan 25 '15 at 0:14
  • This happens to me as well. My hardware is completely different so it can't be an issue with drivers. This seems to be directly related to the recent update of the Chrome itself. – Homulvas Jan 26 '15 at 13:01
  • @Homulvas: It can still be related to hardware drivers if it fails across a broad range of hardware, which I find likely, because Google tweaks their hardware acceleration a great deal and Linux graphics drivers are plenty and often in a sad state. – David Foerster Feb 26 '15 at 13:30
  • It happens to me as well (rarely). Dell laptop with Intel graphic card. – Ljiljan Veselinovic Jan 23 '16 at 16:57
  • As of one of the more recent updates, when I go to a YouTube page, the player shows "An error has occurred" for about 30 seconds and then the video will load. Making a video full screen often makes the desktop freeze. Audio will continue playing in the background, I even carried on a Skype phone conversation once when it froze on me, but I couldn't click on anything. Upon playing a fullscreen video in Firefox I see that they've added a fancy fade animation, but it works fine, which confirms that Chrome is the problem and not Compiz or Ubuntu. – Gerowen Mar 16 '16 at 6:27
6

Got the same issue ever after the Chrome 40.0.2214.91 release, and though I haven't tried the .93, I can at least confirm the issue is 100% gone in Chrome 41 Beta.

Strongly considering sticking to the beta until 41 becomes stable, or at least until it's 100% confirmed a point release fixed the issue.

  • I can confirm that 41 beta works great! – Koppie Jan 27 '15 at 17:52
  • 2
    This issue is back. I'm using chrome 47 beta, but I guess it happens with earlier versions too. – starbeamrainbowlabs Nov 1 '15 at 8:50
  • 2
    Actually, the issue had gone from Chrome 41 to Chrome 47, but since then it seems to be back, and still there as of Chrome 49 Beta. I opened a ticket on the Chromium issue tracker, but nothing has come out of it since then.. – Philippe Lepaffe Feb 2 '16 at 16:15
  • Can confirm. @PhilippeLepaffe can you post a link to the issue here for followup? – Madara Uchiha Feb 16 '16 at 12:28
  • @MadaraUchiha I opened one of them, that hasn't seen a lot of activity (there). This one is for the same issue but there's been a bit more going on. – Philippe Lepaffe Feb 17 '16 at 14:39
28

It seems like the problem reappeared with Chrome version 49. Below is a workaround that will solve the problem until Chrome fixes this bug. It works without disabling hardware acceleration in Chrome (and potentially causing other issues).

  1. If compizconfig-settings-manager is not installed, install it by

    sudo apt-get install compizconfig-settings-manager

  2. Launch compizconfig-settings-manager by typing ccsm from the terminal

  3. Double click to open the Composite plugin

  4. Add & !(class=google-chrome) at the end of the Unredirect Match text box (see screenshot below).

    Composite Plugin Window

  5. Close the settings manager.

  6. Be scared no more to click on Full Screen!

Source: https://bugs.chromium.org/p/chromium/issues/detail?id=550091#c43

  • I will try this as last chance. – Interesting Knox Apr 4 '16 at 6:59
  • This solved my problem that chrome wouldn't go complete fullscreen (no crash but it kept staying within the browsing frame). – runDOSrun Apr 25 '16 at 19:49
  • This helped me on ver 50 too! – mladj0ni May 25 '16 at 20:06
  • 1
    Still freeze at another video website on Google Chrome 55.0.2883.87 – updogliu Jan 2 '17 at 19:37
  • 15
    on ubuntu 16.04 & !(class=google-chrome) was already in the match list, but when i clicked the 'grab' button to select the window it said 'Google-chrome' - so adding & !(class=Google-chrome) actually fixed it for me! thank you1 – Tom Carchrae Jan 12 '17 at 20:38
9

I tried upgrading to

40.0.2214.93

It does not help much. after a while the problem start again, as it is mentioned by other users above.

The one worked for me is this - disable the hardware acceleration settings. in google chrome. For disabling hardware acceleration - go to the option "customize and control google chrome" the gray area in upper right corner besides the option of Google input tools- Google Chrome Tool Bar

Then click on settings from the drop down menu. click on the blue option

Show advanced settings...

check for the 16th category -

System

and see if the box for using hardware acceleration is checked

system

if it is checked please uncheck it.

hardware acceleration

This has solved my problem.

  • 1
    Works for me too. The Issue was reproduced on chrome 46.0.2490.80 – SILINIK Oct 24 '15 at 16:43
  • 2
    Warning: This breaks WebGL. – starbeamrainbowlabs Feb 10 '16 at 16:22
  • @starbeamrainbowlabs when do you receive this warning? after making suggested changes? – sangharsh Feb 10 '16 at 17:46
  • @sangharsh No I didn't receive a warning, I am giving a warning. Try disabling hw acceleration and then visiting get.webgl.org – starbeamrainbowlabs Feb 10 '16 at 18:05
  • 1
    As of today 15.10 64 bit the problem is partially solved with HW acceleration is solved with the last update. Except when the full-screen is called with F11. From JavaScript API it works but not from the browser itself which points the problem out of the browser now I think. – userDepth Feb 11 '16 at 13:00
3

Chrome 40.0.2214.93-1 was released and the problem seems to be gone much better now. Similar symptoms still occur some times but much less frequently. It seems that this problem only affected started with the 40.0.2214.91-1 release. So if you're running that version do sudo apt-get update && sudo apt-get upgrade to update to a more current version.

1

Ok, so i've upgraded to Chrome version 40.0.2214.93 (64-bit) and the problem is gone now. It was suggested by another answer (which is now removed) that the problem only occurred in the Chrome 40.0.2214.91 release.

sudo apt-get update && sudo apt-get upgrade should work if you experience the same problem. Then check out your version number in chrome at the About Google Chrome menu.

UPDATE: After some days of consistently working, It has now gotten problems again, and even with netflix. I'm trying out the beta now too.

  • I removed it because the problem is not completely gone. Everything seemed fine at first then after some time the cursor disappeared again and everything was pretty much locked. Even though this time the video was still playing without any video stutter when minimized I had to kill the session anyway. – Homulvas Jan 27 '15 at 12:16
  • For me it's still consistently gone, I've watched a couple of videos now. I guess you should try out the 41 Beta release, as suggested by Philippe. Hopefully that will fix it for you too. – user717572 Jan 27 '15 at 17:21

protected by Community Jan 20 '17 at 16:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.