Trying out Ubuntu Intrepid, I have discovered that RightAlt+F1 doesn't take me to tty13.

I've exhaustively tried every option presented to me in dpkg-reconfigure console-setup, the best I've been able to manage thus far has been to have both Alt keys behave the same (LeftAlt+F1 and RightAlt+F1 both going to tty1).

Please note that using GNU screen is not considered a valid response to the question - this is specifically about how to get the keyboard to behave properly with multiple consoles under Ubuntu. The crazy thing is that every other distro I've tried just handles this correctly, including Debian Lenny.


6 Answers 6


After a lot of attempts to fix this various ways, I finally figured out how to use dumpkeys and loadkeys to modify the kernel's "keyboard translation table". Here are the loadkeys strings to set RightAlt+F1 through RightAlt+F12 to their respective offsets from tty12:

altgr   keycode  59 = Console_13
altgr   keycode  60 = Console_14
altgr   keycode  61 = Console_15
altgr   keycode  62 = Console_16
altgr   keycode  63 = Console_17
altgr   keycode  64 = Console_18
altgr   keycode  65 = Console_19
altgr   keycode  66 = Console_20
altgr   keycode  67 = Console_21
altgr   keycode  68 = Console_22
altgr   keycode  87 = Console_23
altgr   keycode  88 = Console_24

Why Ubuntu doesn't include this in the default setup remains a mystery. :)


On most systems, if you are at a text console, you can use Alt + the arrow keys to move to next and previous console.


In Debian, I would just edit /etc/inittab, but Ubuntu uses Upstart.

Apparently, you're supposed to edit /etc/default/console-setup and set the ACTIVE_CONSOLES variable to be /dev/tty[1-13] in your case.

Before changing this, Right-Alt + Ctrl + F1 would bring me to tty1. Now, I just get a blank screen that I can't do anything on. I also had to manually copy the file /etc/event.d/tty1 to /etc/event.d/tty13 and change the settings inside appropriately.

I can't seem to get it to work.


  • I have no trouble getting tty13 to start, it's simply a question of how do I get to it once it's started (other than LeftAlt+F12 followed by LeftAlt-RightArrow), but thanks. :)
    – TML
    Feb 3, 2009 at 5:36
  • Blank screen may be a (second) X window
    – gbarry
    Feb 13, 2009 at 23:13

There's a nice program called chvt that takes you to another virtual console. (e.g. 'sudo chvt 1' would pop me right out of X, right now.) It's a bit obnoxious in that X drivers don't always like vt-switching. On the other hand, it's saved me more than once when X has gotten wedged. You might also want to look at a program called "open" which opens a new virtual terminal.

...But if your problem is really that you want more terminals, what I'd really recommend is to look into screen. It does all kinds of nifty things. Like being able to ssh in and connect to the same session you worked on locally, in what I think of as "multiplayer".. (well, you can be attached to the same (backend-) session from multiple frontends.) It kicks ass. I use it every day at work, where I have a very long-running session on one of the anarchic dev-servers.

As for your actual reported problem, well.. hmm.. how's your keyboard configured? Does it work with some more 'popular' keymap?

  • I've exhaustively tried every keymap available. I'm fully aware of screen, and use it daily for remote sessions, but there are features of a vt that screen can't give-e.g., the (gpm) mouse support is spotty at best. As I'm not using X I'll see if I can discover some way to map chvt to keystrokes.
    – TML
    Feb 13, 2009 at 9:08

Are you running X? If so, check your Gnome or KDE keyboard shortcuts to make sure that this isn't bound to something else.

If you're not using X, then why not just use "screen" for console / shell management? That's a much more elegant solution than relying on Linux's multiple consoles. man screen

  • 2
    Thanks for responding. As I mentioned earlier to Anders Eurenius, there are a number of features that a true "VT" gives that are missing from GNU screen - the biggest one being the inconsistent support for the console mouse server "gpm".
    – TML
    Feb 18, 2009 at 18:42

Mostly, virtual consoles tty8 through tty63 are unused and unassigned. There's no applications running on them, and they're not assigned to any keypress. However, you still can open an application on it as described in one of my older answers:

  1. Make your user the owner of that console: sudo chown "$USER":tty /dev/tty13
  2. Run openvt -c 13 -l or openvt -c 13 -s "bash"
  3. If you return to TTY1 or any other tty that has assigned keyboard shortcut, and want to go back to the TTY13 that you've opened, use sudo chvt 13 for that ( and if I'm not mistaken - if you're added to tty group you should not need sudo for that ).

If you add yourself to tty group, you can later skip the step #1 and assign the command in step #2 as keyboard shortcut

Please also note that proper combination is Ctrl+Alt+F1 and not Left Alt+F1 indicated in the question body. For virtual machines in Virtual Box, that's slightly different - it's Left Ctrl+F1.

  • Ctrl+LeftAlt is only required if you're trying to get away from X; if you don't run X, LeftAlt+F1 takes you to terminal 1…LeftAlt+F12 to terminal 12, while RightAlt+F1 is supposed to take you 13…RightAlt+F12 to terminal 24.
    – TML
    Mar 10, 2020 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.