0

I upgraded yesterday from xUbuntu 14.04 to 14.10, because I hoped to have better bluetooth recognition. (I didn't).

Before the upgrade

Wifi would drop out seemingly randomly. More often, when there was more space/stuff between me and my router, but also when nothing changed.

Time could be between 2 days and (in extreme cases) a few minutes.

I need to disable-enable the whole network by using the dropdown menu, because after losing connection the SSID of the router is not in the menu for me to choose. The router itself does not lose connection to any other device and I'm connected to it again after 5 seconds, after re-enabling the network.

After the upgrade

Wifi drops out faster now ~10-30 minutes.


I already tried this solution. But it didn't work.

Output of 'The Script' (too long): http://paste.ubuntu.com/9850671/

Any further information will be gladly provided. I would be very grateful for some help and even a little explanation what the problem is if possible.

Update 1

Jan 24 17:21:37 Laptop kernel: [ 7755.037954] wlan0: deauthenticated from xx:xx:xx:xx:xx:xx (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA)

This line appears everytime my connection drops. Might be connected with this bug

Update 2

For the time being, I made a script automatically reconnecting me.

#!/bin/bash
while :
do
        if ! ping -c 1 -W 4 192.168.2.1 >/dev/null; then
                notify-send 'Network gone down' 'Reconnecting...'
                nmcli nm enable false;
                sleep 0.5;
                nmcli nm enable true;
                sleep 10
        fi
        sleep 1
done

IP address might need to be changed. I'm not fit in networking. It may also produce some false positives. It is a hack, after all. Still better than manually clicking through menus every time.

Update 3

Current output of 'The script': Here

Cross posted the question to the ubuntu forums as adviced.

0

Change your router from auto or whatever channel it is on to a channel not occupied, the following is from the script and you are one of them on channel 11

Channel occupancy:

  1   APs on   Frequency:2.412 GHz (Channel 1)
  3   APs on   Frequency:2.437 GHz (Channel 6)
  1   APs on   Frequency:2.447 GHz (Channel 8)
  5   APs on   Frequency:2.462 GHz (Channel 11)

The fix you found and the bug are not applicable to your wifi card, an Intel Centrino N135

One thing that could help with 11N speeds is echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf reboot and check results

Try disabling the Ubuntu firewall.

sudo iw reg set DE and reboot and possibly test with TLP disabled, the new results look like you should have a working wifi connection

  • I changed my channel to channel 1. Could you elaborate what 11N speeds mean? 802.11n? – Minix Jan 25 '15 at 13:13
  • 11n allows transfer speeds up to 600 Mbps whereas 11g allows up to 54 Mbps. If you edit the file using gksudo gedit /etc/modprobe.d/iwlwifi.conf change the command to 11n_disable=1 it will disable 11n but still will allow 11 a/b/g – Jeremy31 Jan 25 '15 at 13:45
  • I added 11n_disable=8 to the conf file and restarted. Unfortunately it did not change anything. Changing it to 11n_disable=1 did not help either. – Minix Jan 25 '15 at 14:01
  • Disable firewall(UFW) as it is blocking some traffic it shouldn't – Jeremy31 Jan 25 '15 at 14:26
  • Will disable it with sudo ufw disable and report back. Can you explain, how you saw, that the ufw is messing up? – Minix Jan 25 '15 at 14:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.