5

This question already has an answer here:

I have an installation of wine on my Ubuntu 14.04 (minimal) system (with xfce):

sudo apt-get install --no-install-recommends wine

I wanted to run .NET applications with it. When I use a GUI (File manager) to execute such an application with wine for the first time, a message from wine is displayed telling me that mono is not installed. It then prompts me to install mono for wine. If I proceed, it downloads and installs it and everything works fine, i.e., I can execute .NET applications with wine.

Now, since I want to create an automated install script for various applications (including wine and mono for wine), I was looking for a package that does what I described above, but without the GUI and, more importantly, without user interaction. I found the wine-mono0.0.8 package, which I tried to install:

sudo apt-get install --no-install-recommends wine-mono0.0.8

However, even after it is installed, wine complains that mono for wine is not installed, refusing to run .NET applications. I also tried winetricks (from the package with the same name), but not only did the installation fail - it required user interaction in the setup.

My question now is: Is there an alternative way to install wine for mono (like it does when started in a GUI for the first time), but without the need for user interaction? Alternatively, is there another package like wine-mono0.0.8 which works, i.e., makes wine recognize the mono installation?

Best regards Andreas

marked as duplicate by kenorb, Eric Carvalho, karel, Fabby, Thomas Jan 6 at 16:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Try answer here askubuntu.com/questions/399536/wine-1-7-9-and-mono-package . possibly counted as duplicate – user.dz Jan 24 '15 at 15:19
  • 1
    If you can't get it to work try using this ppa or just download only needed package and install it using sudo dpkg -i ... launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa/… – user.dz Jan 24 '15 at 15:25
  • @Sneetsher: So, this means that the package is simply broken or delivering a broken version? This seems strange to me since the related question that you linked to describes a similar problem, but is more than a year old. I'll try the PPA. – Andreas Unterweger Jan 24 '15 at 17:40
  • 1
    Update: It seems to be a problem with the (Ubuntu) wine package. If I keep that and install wine-mono4.5.4, the problem remains; but if I remove the (Ubuntu) wine package and install both, the wine1.7 and the wine-mono4.5.4 package from the PPA, it works. – Andreas Unterweger Jan 24 '15 at 19:24
  • @Sneetsher: I'll do that. But I would, in addition, be interested in what happens behind the scenes when I make wine install mono by itself (as described above). If I could replicate this (in an easy way), I would prefer it to adding a PPA. – Andreas Unterweger Jan 24 '15 at 21:27
6

Please note that the repository suggested here is deprecated. Refer to here for more information.

It seems to be a problem with the (Ubuntu) wine package. Installing both, the wine1.7 and the wine-mono4.5.4 package, from the wine PPA, works.

The steps are as follows:

  1. Remove the (Ubuntu) wine package (if it is installed): sudo apt-get remove --purge wine
  2. Add the wine PPA to the package repositories: sudo add-apt-repository ppa:ubuntu-wine/ppa && sudo apt-get update
  3. Install the wine and wine-mono packages from the PPA (adjust to newer version numbers if necessary): sudo apt-get install wine1.7 wine-mono4.5.4

Thanks to Sneether for pointing out the PPA.

  • does not work on UBUNTU 17.10, repo has no "Aardvark" packages for wine and mono ... – Jiří Doubravský Jan 13 '18 at 17:26
3

mono for wine is not installed, refusing to run .NET applications

You can try installing .NET framework it-self, e.g.

sudo apt-get install winetricks
winetricks dotnet45

Not the answer you're looking for? Browse other questions tagged or ask your own question.