28

In Ubuntu 14.04, when I do a search in Firefox using either the address bar or the search bar, the system always adds t=canonical to my searches. So the full string becomes: https://duckduckgo.com/?q=cat+cooking+salmon&t=canonical.

However, if I perform the same search by going directly to the search engine, i.e. typing the search engine name and doing the search from the presented search box, this does not happen. In this case the string is: https://duckduckgo.com/?q=cat+cooking+salmon.

Search made directly by going to DuckDuckGo

How do I stop Ubuntu/Firefox from adding t=canonical to my search queries? And, why is this behavior there in the first place?

  • 2
    But wait! It gets better! This is a screenshot taken in Chrome, on a Mac. i.imgur.com/WbW2d1M.png – jrg Feb 27 '15 at 14:28
  • So it gets infested across the entire ecosystem, and follows it from browser to browser, and platform to platform. – jrg Feb 27 '15 at 14:33
  • 3
    Note that even if you remove this from the querystring, your browser is still broadcasting "Ubuntu" in the user-agent string. – Oli Feb 28 '15 at 15:28
  • 1
    It is so hard to make money in "pure" Open Source. Why not support Ubuntu Linux in this small way? – lnostdal May 18 '16 at 14:34
  • @lnostdal: "It is so hard to make money in "pure" Open Source. Why not support Ubuntu Linux in this small way?" --- Privacy, although I was more interested in learning the how/why. – Daniel May 18 '16 at 20:41
30

&t=

Through partnerships with developers and companies, DuckDuckGo has been integrated into many applications. In these partnerships, a portion of DuckDuckGo's advertising revenue is sometimes shared back. To assign advertising revenue and collect anonymous aggregate usage information, developers add a unique "&t=" parameter to searches made through their applications.

If you want to remove it, edit the file:

/usr/lib/firefox/distribution/searchplugins/locale/*language-here*

Edit all the languages just to be sure.

enter image description here

Source:DuckDuckGo Forums

  • After commenting the line with <!--<Param name="t" value="canonical"/>--> and restarting Firefox the t=canonical no longer shows up. Also thumbs up for the link to DDG forums. – Daniel Jan 24 '15 at 20:18
  • After an update the files were back with their original content so I had to repeat these steps. – Daniel Mar 21 '15 at 13:50
  • 1
    so it's the Canonical (Ubuntu parent) getting the revenue and not FF which initiated the search in the first place? – asgs Nov 23 '17 at 6:56
7

Read the output from apt-cache show xul-ext-ubufox. Here's a partial quote:

Package: xul-ext-ubufox
Priority: optional
Section: web
Installed-Size: 378
Maintainer: Ubuntu Mozilla Team <ubuntu-mozillateam@lists.ubuntu.com>
Architecture: all
Source: ubufox
Version: 2.8-0ubuntu1
Replaces: ubufox (<< 0.9~rc2-0ubuntu3)
Provides: firefox-ubufox, ubufox
Depends: aptdaemon, libglib2.0-0 (>= 2.26)
Recommends: firefox (>= 9.0)
...
Description-en: Ubuntu-specific configuration defaults and apt support for Firefox
 Adds Ubuntu-specific modifications to Firefox.
 .
 Integrates the browser with Ubuntu to:
  * Enable searching for missing plugins from Ubuntu software catalog
  * Add the following options to the Help menu
    - Get help on-line
    - Help translating Firefox
    - Ubuntu Release Notes
  * Set homepage to Ubuntu Start Page
  * Display a restart notification after upgrading Firefox
  * Add ask.com to the search engines.
 .
You can uninstall this if you prefer to use a pristine Firefox install.
Enhances: firefox
Homepage: https://launchpad.net/ubufox

Note the third-last line.

As for why, Canonical may earn some revenue but that's just speculation.

1

I am using Firefox 60.0.1 on Xubuntu 16.04.4 (64-bit). I had the same problem you face. The chosen answer provided by Mitch did not work for me. Instead, I resolved the issue by following this procedure:

  1. Open Firefox, navigate to Preferences -> Search, and remove the pre-installed DuckDuckGo search engine
  2. Download the search engine anew from the Firefox Add-ons directory; it can be found here
  3. Select this as the default search engine in the preferences

The string, &t=canonical, ceased to insert itself into my searches via the address bar thereafter.

I cannot tell you why the behaviour is there in the first place.

1

To remove "canonical" and other non-standard ubuntu things from firefox search string, delete contents of "/usr/lib/firefox/distribution/searchplugins/locale/" directory.

0

The above answers not working on a new versions of firefox. Because of that I recommend downloading firefox from official website and making a symlink

sudo ln -s /path_to_downloaded_firefox_executable_file /usr/bin/firefox
0

Since Firefox 45, search engines are stored in search.json.mozlz4, as noted on reddit. This file may be found in the profile directory at $HOME/.mozilla/. The file can be decompressed, edited, then recompressed.

The mozlz4 format has a custom header that prevents it from working with standard lz4 compression utilities. For methods to decompress and recompress them, see How to decompress jsonlz4 files (Firefox bookmark backups) using the command line?

Alternatively, delete search.json.mozlz4 after editing the xml files located at /usr/lib/firefox/distribution/searchplugins/locale/, as Mitch♦ suggests; or deleting them, as Kindly recommends. Firefox will regenerate the mozlz4 file when it is next started. If the file is not deleted, the changes made to the xml files will have no effect.

Other solutions that don't appear to work:

  • Attempting to reinstall the search plugin after deleting it from preferences, as Komalleana suggests, gave me an error stating that the search engine was already installed, even after restarting Firefox and confirming that it did not appear in the list.

  • Changes to the xml files are no longer contained in xul-ext-ubufox, which DK Bose mentions. Some are now in the firefox package. Others are in the firefox-locale-* packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.