0

I have dual booted Windows 8 with Ubuntu 12.04. When I use Windows the temperature remains normal but when i use Ubuntu my laptop gets heated up and the temperature goes to 70-90 degrees C just after 5 minutes and remains above 70 degrees after that. I have tried lots of things but nothing worked. I installed Jupiter, tried disabling the graphis but don't know why it's not getting disabled. Is there any solution?

rittik@dell:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Physical id 0: +84.0°C (high = +87.0°C, crit = +105.0°C)
Core 0: +80.0°C (high = +87.0°C, crit = +105.0°C)
Core 1: +84.0°C (high = +87.0°C, crit = +105.0°C)

0

Is it just overheating, or are you experiencing power consumption problems as well? You could try and limit the CPU frequency at which your box operates by using a nifty little program called "cpu-freq", works great on my Dell running Ubuntu 14.10.

Link to info (basically doubled my battery life) http://www.noobslab.com/2013/07/how-to-improve-laptop-power-management.html

5
  • battery works for 2 to 2 and half hrs so it drains in less time than usual and can you please elaborate on what you are telling about nifty?
    – rittik
    Jan 24 '15 at 8:09
  • noobslab.com/2013/07/… (site helped me out a lot when I was first setting up my box)
    – Tylobyte
    Jan 24 '15 at 8:11
  • If this did help, let me know, I love helping out other members of this community, plus I need a decent rep score to tackle some of the bigger questions posted here. :D enjoy!
    – Tylobyte
    Jan 24 '15 at 8:43
  • Its not working.
    – rittik
    Jan 24 '15 at 10:44
  • hmmm. you installed the software via the scripts?
    – Tylobyte
    Jan 24 '15 at 21:16
0

Use nbfc to control your fan

I use an Acer Aspire E5-573G nothing else worked to control the CPU fan, but nbfc. I'm using Ubuntu 18.04. The exact profile for my model is missing, but nbfc worked fine with another similar profile (Acer Aspire E5-575G). If you don't know which profile to use, you can try: mono nbfc.exe config -r

Also I edit the default profile to turn the fan policy more aggressive.

Build it on Ubuntu

You need the latest mono version, so update it, as required:

sudo apt remove mono-complete
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/ubuntu stable-bionic main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update
sudo apt install mono-complete

Clone the git repository, build

# git is needed, so install it
sudo apt install git

# clone the repository into /tmp/nbfc
git clone https://github.com/hirschmann/nbfc.git /tmp/nbfc
cd /tmp/nbfc

# Build NBFC
./build.sh

# After the build, "install" nbfc as properly
sudo mkdir /opt/nbfc
sudo cp -r /tmp/nbfc/Linux/bin/Release /opt/nbfc/
sudo cp /tmp/nbfc/Linux/{nbfc.service,nbfc-sleep.service} /etc/systemd/system/
sudo systemctl enable nbfc --now

# Now you need to discover a profile for your machine .
# All profiles are into /opt/nbfc/Configs as XML files
cd /opt/nbfc

# Run the following to discover a similar profile to your machine
mono nbfc.exe config -r

# Use one profile from the suggest list the previous command  
mono nbfc.exe config --apply "Config file name without extension"

# Now start the service
mono nbfc.exe start

# To show what is happen with your fan/machine, run
mono nbfc.exe status --all

The nbfc project wiki is very rich and well documented. Take a look if you have some doubt. Good luck.

2
  • It's generally frowned upon to spam the same answer to so many questions, even if the answer might be useful. Aug 14 '20 at 22:56
  • Sorry, @MerlijnSebrechts. I just think it can help a lot of people with the same problem. I tried everything and nothing else worked.
    – marciowb
    Aug 14 '20 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.