2

I have bought an Alcatel x602D modem for 3G Internet connections but Ubuntu doesn't recognize it as a modem but like USB storage

How should I proceed?

0

What you have is called a "multi-mode USB device": It's a modem and also a USB stick: and it usually has Windows and Mac drivers on-board! When plugged in on Windows or the Mac, it acts like a flash storage and starts installing the drivers from there. After installation (and on every consecutive plugging) the driver switches the mode internally...

However, when you're Using Linux, this is just a minor nuisance as you can install USB_ModeSwitch which will allow you to use some Alcatel products as a modem. So just remove the modem from your PC and type:

apt-get install usb-modeswitch

In 90% of cases you then just have to insert the modem and it'll work like a modem!

If you're in the 10% where the Ubuntu repository doesn't work, download the latest usb-modeswitch-data package (dated 2015-01-15 at the time of this writing) and extract it (as root) over the existing data package. (use locate usb_modeswitch.d to find the correct directory)

If that doesn't help you either, download the latest binary package from Debian and install it over the existing package. (it will now be quite impossible to automatically uninstall and you will have to use the same manual method to upgrade USB_ModeSwitch from this point forward until you reinstall your OS)

To convert Debian code names to Ubuntu code names, use the following table:

15.04        jessie / sid
14.10        jessie / sid
14.04        jessie / sid
13.10        Wheezy / sid
13.04        Wheezy / sid
12.10        Wheezy / sid
12.04        Wheezy / sid

If all that still doesn't work, follow the trouble-shooting guide and if that doesn't work, contribute...

| improve this answer | |
  • As you're a reputation 1 user: If this all works, don't forget to click the grey check-mark under the "0" at the left of this text, which means "yes, this answer is valid"! ;-) – Fabby Jan 26 '15 at 9:32
  • i've tried usb-modeswitch but didn't work for me and also tried Sakis3G but neither worked i had to remove ubuntu with all my things and install windows but i don't like this os since i use linux but i only have a modem 3g to connect to the internet , any help i'll appreciate it – bilalsbz Jan 26 '15 at 23:13
  • What step in the process of usb-modeswitch didn't work? Did you try the latest version? Or only the one from the Ubuntu repository? Did you file a bug? – Fabby Jan 26 '15 at 23:17
  • i installed it from the ubuntu repository ,i thought its work automatically,becouse i didn't find a toturial or step to set up this model (alcatel onetouch x602d) – bilalsbz Jan 27 '15 at 1:31
  • How to set up the alcatel onetouch x602d modem itself is another question. This answer is only about turning off the USB storage (which was your original question) I'll edit my answer as you're apparently in the 10% where turning off the USB storage doesn't work from the standard Ubuntu repositories. – Fabby Jan 27 '15 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.