1

I have had problems with NVIDIA drivers for a while.

Now I got a problem: In additional drivers I get 331.113, as this link http://www.nvidia.com/Download/driverResults.aspx/80533/en-us shows, it is compatible with my NVIDIA GeForce GT610 GF119 graphics card.

But, when I search for my GPU on NVIDIA site (http://www.geforce.com/drivers), I don't get 331.113.

Is the 331.113 driver compatible [with my GPU]?

And, which driver works the best for my card and has the least bugs?

I'd really like to know that, as well as installation information.

  • The 331.113 Nvidia drivers is compatible with the GeForce GT 610 graphics card. Also it might be worth upgrading to 346.35 as that is also compatible with your card and it is the newest version. – Michael Lindman Jan 23 '15 at 21:46
0

Note: According to Nvidia website, your video card has been supported since 295.53

http://www.nvidia.com/object/linux-display-amd64-295.53-driver

Added support for the following GPUs:

GeForce GT 610
  :

Be slightly conservative. You may want a later version (to better support your device), but do not want to be bleeding edge.

Unless you want to always download and compile (every OS update), use one of the provided PPAs.

See: Update nvidia drivers with xorg-edgers ppa

Use @robblue2x's method, and try 340.58

Note: 331 is only 331.104 (not 311.113); and 346.nnn is very latest.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.