1

The sound is working when I switch to RGB but it's not working when I switch to HDMI (DVI-HDMI).

Why is there no sound when using DVI to HDMI adapter? How can I fix it?

    **** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Monitor is 32LG80. (HD TV WITH BUILTIN 3.2 CH SURROUND SOUND) Using DVI-D (Dual link) to HDMI adapter and a 3.5mm stereo audio cable. Not using any graphic card. Motherboard: Intel DH55PJ


Cables: DVI to HDMI which doesn't support audio and a 3.5mm stereo cable.

While using Windows 8.1:

  • Config: TV input is HDMI -- Both audio and Video working.

While using Ubuntu 14.04:

  • Config: TV input is HDMI -- Audio not working, Video working.

  • Config: TV input is RGB -- Audio working, Video not working.


Cables: VGA and a 3.5mm stereo cable

While using Windows 8.1:

  • Config: TV input is HDMI -- Both audio and display working.

While using Ubuntu 14.04:

  • Config: TV input is RGB -- Both audio and display working but the display resolution is limited to 1024*768 while the native resolution is 1366*768.
  • Please post the output of aplay -l. – joeeey Jan 24 '15 at 3:42
  • 1
    Whilst using DVI/HDMI, check the analog audio device is enabled/unmuted. – NGRhodes Jan 24 '15 at 10:42
  • I have the same experience and have not solved it yet. However to add some more info. My TV can tell the difference between 1080p and 1920x1080@60hz. When in 1080p mode it expects audio through the HDMI but the DVI output on the graphics card does not do this. When in 1920x1080 mode it uses the input from the audio jack. I have found changing the resolution to one the TV does not expect audio in the HDMI works. However what I and the original poster would be looking is for the Video stream to correctly Identify it self as 1920x1080 and not 1080p (this is the resolution we would like). Noting t – user455116 Sep 27 '15 at 6:47
2

To have DVI sound coming through an HDMI adapter, you need to be using a DVI-D connector with a graphics card that supports transmitting audio over DVI.

From Wikipedia:

DVI-D devices output HDMI signals, many including audio, (examples: ATI 3000-series and NVIDIA GTX 200-series video cards), and some multimedia displays input that HDMI signal, including audio, by using a DVI to HDMI adapter. Exact capabilities vary by video card specifications.

According to the above snippet from Wikipedia, it also seems that the display needs to support the input from a DVI to HDMI adapter.

Otherwise, it doesn't look like DVI supports audio.

  • 1
    I'm using an analog audio cable. Still audio can be heard only when the monitor is in RGB mode, When in HDMI mode there's no sound. Is there any workaround? – Venkat Ch Jan 23 '15 at 22:13
  • It sounds like in HDMI mode, the TV is expecting audio to come through the HDMI cable. Since you are using a DVI cable that doesn't support audio, you can't hear anything. – joeeey Jan 23 '15 at 22:22
  • This must be the displays issue. Ubuntu has no control of what source the TV is checking for audio. – joeeey Jan 23 '15 at 22:24
  • But it worked in Windows 8.1? – Venkat Ch Jan 23 '15 at 23:58
  • 1
    Hi. I've edited the question. It's known that my DVI to HDMI cable can't produce audio. I'm using 3.5 mm stereo cable for audio. The audio is working by default in Windows 8.1. But it's not working in Ubuntu., Maybe in Ubuntu the default audio is set to HDMI? Can we force the operating system to use 3.55 cable for audio instead of HDMI? Thanks! – Venkat Ch Jun 10 '15 at 18:08
0

Pulse Audio automatically switches audio output to HDMI when an HDMI connection is established.

A great tool you can use to overcome the various pitfalls of Pulse Audio is alsamixer.

Just to make sure it's installed, go ahead and run the following command:

sudo apt-get install alsa-utils

Then, connect the HDMI connection with the connection set to DVI-HDMI.

Next, run the following command in a terminal:

alsamixer

and then press F5 to view all channels.

You should see multiple channels. If you see only one channel for pulseaudio, you may need to press F6 to select a different card. However, if you do see multiple channels after pressing F5, continue.

Use the arrow key to scroll to the right and press the up arrow key to toggle the automute option to switch it off.


Now, there are two possibilities here.

First:

I think HDMI audio and analog audio are handled by two separate sound cards so you should have the option to select the analog stereo out sound card by pressing F6.

You should see something similar to the following example. This example shows only one analog output card. Should you have an extra digital card listed, switch to the analog card instead (HDA Intel PCH is a very common card for analog output).

                         ┌───── Sound Card ──────┐
                         │-  (default)           │
                         │0  HDA Intel PCH       │
                         │   enter device name...│
                         └───────────────────────┘

Alternatively:

When using the standard 1/8th in. (3.5mm for you metric people) stereo headphone jack for audio, this channel automatically goes to 0 when you switch to another out such as, built in speakers or HDMI. If this is the case, you simply need to go to the headphone channel and raise the volume using the arrow up key. Some desktop computers have multiple channels for front back, etc. Locate the correct output channel and raise the volume.

Another possibility is that the channel may be muted. If a channel is muted, it will say MM at the base of the indicator for that channel.

In any case and whatever channel it is, headphone out or not, select the channel using the right or left arrow key.

Then, press the M key to toggle mute off or on. Be careful here to have the volume at a safe level so that unmuting the device will not blow your speakers!!

Here is an example showing three muted channels:

┌──────────────────────────────────────────────────────── AlsaMixer v1.0.28 ─────────────────────────────────────────────────────────┐
│ Card: HDA Intel PCH                                                                                        F1:  Help               │
│ Chip: Conexant CX20590                                                                                     F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All                                                                   F6:  Select sound card  │
│ Item: Speaker [dB gain: -4.00, -4.00]                                                                      Esc: Exit               │
│                                                                                                                                    │
│       ┌──┐            ┌──┐            ┌──┐            ┌──┐            ┌──┐            ┌──┐                            ┌──┐         │
│       │  │            │  │            │  │            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │  │            │  │            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │  │            │  │            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │▒▒│                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │▒▒│                            │▒▒│         │
│       ├──┤            ├──┤            ├──┤            └──┘            └──┘            ├──┤          Disabled          └──┘         │
│       │MM│            │MM│            │MM│                                            │OO│                                         │
│       └──┘            └──┘            └──┘                                            └──┘                                         │
│        61            85<>85          85<>85          99<>99           0<>0             9                            100<>100       │
│      Master         Headphone   <    Speaker    >      PCM          Mic Boost         Beep       Auto-Mute Mode  Internal Mic Bo   │
│                                                                                                                                    │
└────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┘ 

When the channel is not muted, it should say OO instead of MM like in this example:

┌──────────────────────────────────────────────────────── AlsaMixer v1.0.28 ─────────────────────────────────────────────────────────┐
│ Card: HDA Intel PCH                                                                                        F1:  Help               │
│ Chip: Conexant CX20590                                                                                     F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All                                                                   F6:  Select sound card  │
│ Item: Speaker [dB gain: 0.00, 0.00]                                                                        Esc: Exit               │
│                                                                                                                                    │
│       ┌──┐            ┌──┐            ┌──┐            ┌──┐            ┌──┐            ┌──┐                            ┌──┐         │
│       │  │            │  │            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │  │            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │  │            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │  │            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │  │                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │▒▒│                            │▒▒│         │
│       │▒▒│            │▒▒│            │▒▒│            │▒▒│            │  │            │▒▒│                            │▒▒│         │
│       ├──┤            ├──┤            ├──┤            └──┘            └──┘            ├──┤          Disabled          └──┘         │
│       │OO│            │OO│            │OO│                                            │OO│                                         │
│       └──┘            └──┘            └──┘                                            └──┘                                         │
│        61            85<>85         100<>100         99<>99           0<>0             9                            100<>100       │
│      Master         Headphone   <    Speaker    >      PCM          Mic Boost         Beep       Auto-Mute Mode  Internal Mic Bo   │
│                                                                                                                                    │
└────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┘

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.