6

I have installed Teamviewer 10.0 (32/64 bit multiarch version) on Ubuntu 14.04.

When I bring up the Proxy config window (Extras -> Options -> General -> Proxy Settings[Configure]) all I can do is select is No proxy or Use manual proxy.

So when I choose Use manual proxy, there are fields to enter the proxy IP, username and password but they appear as read-only fields. I cannot type the numbers at all.

I have tried restarting both TeamViewer and Ubuntu, but there is no success.

6

The best solution I found is to follow this steps :

  • Stop Teamviewer by sudo teamviewer --daemon stop
  • Add the following line :

    [int32] Proxy_Type = 2

    in Teamviewer config file at /etc/teamviewer/global.conf

  • Restart Teamviewer by sudo teamviewer --daemon start

It will force Teamviewer proxy settings to be on manual option by default, then the input will be writable. This way you don't have the AES salt problem.

Hope it will work for you.

3

This may give you a clue to get it going - it didn't work for me, but you never know.

Teamviewer 10 has a config file at: /opt/teamviewer/config/global.conf

Based on the conf from a previous install, the format for putting the proxy config keypairs in that config file should be:

[bin  ] ProxyPasswordAES = b92c3b83c5e3c2b23520ff1d31e6687xxxx74bccfc96301bc1df3cd5c1babcd7eaf3a5ae3cfc990373d449184fab9b64
[strng] ProxyUsername = "user" 
[strng] Proxy_IP = "proxy1:3128" 
[int32] Proxy_Type = 2

The ProxyPasswordAES is a 97 character salt(?), I'm not sure how to generate this so I just reused the string from my teamviewer 8 conf. As I said, it didn't work :)

Maybe this will work for you if you're not using an authenticated proxy, or maybe someone with more knowledge than me on getting the password encryption working will respond.

Hope it helps anyway.

  • This worked like a charm for me, without the Proxy Authentication. We don't use it, just need to know the IP and Port. CentOS 6.6 workstation, SquidProxy listening on tcp/3128. Teamviewer does not run as an Enterprise Linux service (chkconfig/service won't help), it's a daemon you have to manage via the steps @NicoTux offered in his answer, sudo teamviewer --daemon start – 0xSheepdog Apr 23 '15 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.