1

This question already has an answer here:

When trying to upgrade to the PPA version of Nemo, I get the following dpkg error:

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  cinnamon-translations python-requests python-urllib3
The following packages will be upgraded:
  nemo nemo-data python-cupshelpers system-config-printer-gnome

Preparing to unpack .../cinnamon-translations_2.4.0-20141104040041-trusty_all.deb ...
Unpacking cinnamon-translations (2.4.0-20141104040041-trusty) ...
dpkg: error processing archive /var/cache/apt/archives/cinnamon-translations_2.4.0-20141104040041-trusty_all.deb (--unpack):
 trying to overwrite '/usr/share/locale/ne/LC_MESSAGES/nemo.mo', which is also in package nemo-data 1.8.4-1.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/cinnamon-translations_2.4.0-20141104040041-trusty_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have tried the usual suggestions that I have been able to find and have even tried deleting the nemo.mo file, but nothing seems to work. Any ideas as to how to get this sorted? I am using Ubuntu 14.04 with Unity, but have Nemo set as the default default fire manager.

marked as duplicate by karel, WinEunuuchs2Unix, vidarlo, Zanna, ravery Jan 28 '18 at 19:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • webupd8.org/2011/02/fix-dpkg-error-trying-to-overwrite-x.html Seems to have solved the problem after having used sudo dpkg -i --force-all – globetrotterdk Jan 24 '15 at 18:49
  • Could you please answer your own question so that schmucks like me who go around hunting for unanswered questions don't have to look at this one any more. ;-) (And I'll upvote if you drop me a note and it's a good one too!) – Fabby Jan 25 '15 at 20:42
1

Answer from OP:

Sometimes when installing/upgrading a package, you get an error about it trying to overwrite some file which is also found in some other package and this results in a error that won't let you install/upgrade that package.

In most cases, such errors occur when some file was moved from one package to another in a newer version. Here is an example of such an error:

Unpacking replacement smplayer ...
dpkg: error processing /var/cache/apt/archives/smplayer_0.6.9+svn3595-1ppa1~maverick1_i386.deb (--unpack):
 trying to overwrite '/usr/share/smplayer/translations/smplayer_eu.qm', which is also in package smplayer-translations 0.6.9-1
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Fixing this (in most cases but probably not all) is quite simple: look for path of the file that caused the error - in my first example that would be /var/cache/apt/archives/smplayer_0.6.9+svn3595-1ppa1~maverick1_i386.deb, and run the following command:

sudo dpkg -i --force-overwrite /var/cache/apt/archives/smplayer_0.6.9+svn3595-1ppa1~maverick1_i386.deb

If --force-overwrite doesn't work, you can try --force-all instead.

In the above command, replace /var/... with the exact path to the .deb that caused the error on your computer.

Source

Not the answer you're looking for? Browse other questions tagged or ask your own question.