I tried to install texlive 2014 on Ubuntu 12.04 using downloaded .iso image file. There are some instructions in the following link: Easy way to install TeX Live (and TeX Studio) in Ubuntu 12.04 After installation completed successfully I tried to check if everything is OK using the following command: "tex --version" but I got the error: "The program 'tex' is currently not installed. You can install it by typing: sudo apt-get install texlive-binaries" how can I fix this problem to use latest version of texlive on my computer?

  • Have you created the symbolic links to /usr/local/bin during the installation ? If not you'll probably need to set your path variable to include the tex bin directory.
    – Harris
    Jan 22, 2015 at 22:28
  • No I didn't. How can I do that? (Actually I'm new to Ubuntu)
    – Cypress
    Jan 22, 2015 at 22:46
  • 1
    Do you know the exact directory that texlive was installed ? Why don't you install the ones from the repositories directly using sudo apt-get install texlive at the terminal ?
    – Harris
    Jan 23, 2015 at 0:32
  • Seems like we need more upvotes on an answer in that question which doesn't suggest to install from TeX Live ISO and install from the packages instead.
    – LiveWireBT
    Jan 23, 2015 at 10:53
  • I installed it to it's default path : (/usr/local/texlive). I didn't use repositories because they have the old version of Texlive.
    – Cypress
    Jan 23, 2015 at 11:10

1 Answer 1


It's important that you just don't follow instructions blindly and also that you make decisions that are appropriate for you. If you're just a beginner choosing the default options and preferring (TeX) packages from the Ubuntu repositories over external sources is the best option.

Stop here and read the last paragraph again...



The instructions you probably followed suggested to not install symlinks, which is why all the resources, like binaries and manpages, are not in your environment (PATH variable) and Ubuntu doesn't know where these are installed or even if they are installed installed.

enter image description here

Also note the directories in the screenshot for a hint if you don't know where you installed TeX live (assuming that these aren't customized).

enter image description here

Correcting the mistake

As the instructions don't seem to provide how to setup the missing symlinks¹, reinstalling to the same location as before, but this time with creating symlinks option enabled, would be one option.

The other option would be to remove what TeX live installed (seems to be in /usr/local but /opt is also a possible location, only remove files and directories related to textlive, other programs may have stored files there too, more details see FHS) and install the version from the repositories. Upgrade to a newer LTS release if you need a newer version of TeX Live

¹ Possbily related: How to install “vanilla” TeXLive on Debian or Ubuntu?

  • I reinstall it and this time I check "Create symlinks In system directories" and every thing is OK this time. Thanks a lot.
    – Cypress
    Jan 24, 2015 at 8:46
  • If following your first solution, reinstalling everything as before, will it overwrite the previous install, or will I have two version installed? Does it see that everything is already there and simply progress to creating the symlinks?
    – n1k31t4
    Mar 24, 2017 at 7:32
  • I'm not sure, better look for a way to remove the old parts first.
    – LiveWireBT
    Mar 24, 2017 at 15:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .