1

I just bought a new Dell laptop with Windows 8 and am attempting to install Ubuntu 14.10. I used Startup Disk Creator with the PC Intel x86 desktop image to create a bootable Ubuntu USB drive with a FAT32 format. I checked the md5sum of the .iso file and it matched the official md5sum. I booted the new PC from it and it showed these lines of output.

[    4.425830] isapnp:Write Data Register 0xa79 already used
[   10.132399] [drm:sl_dpm_enable] *ERROR* radeon: sl_init_smc_table failed
[   10.132424] [drm:radeon_pm_init_dpm] *ERROR* radeon: dpm initialization failed
[   10.575523] [drm:r600_ring_test] *ERROR* radeon: ring 0 test failed (scratch(0x850C)=0xCAFEDEAD)
[   10.575558] radeon 0000:04:00.0: disabling GPU acceleration
[   10.820170] ------------[ cut here ]------------
[   10.820194] kernel BUG at /build/buildd/linux-3.16.0/drivers/gpu/drm/radeon/radeon_s8.c:321!
[   10.820225] invalid opcode: 0000 [#1] SMP
[   10.820245] Modules linked in: rtsx_usb_sdmmc rtsx_usb usbhid hid  uas usb_storage radeon 1915 ahci tta psmouse libahcl 12c_algo_bit drm_kms_helper r0169 drm all 
[   10.820330] CPU: 0 PID: 209 Comm: plymouthd Not tainted 3.16.0-23-generic #31-Ubuntu
[   10.820367] Hardware name: Dell Inc. Inspiron 5548/079JDM, BIOS AO2 12/04/2014
[   10.820394] task: ebaadcd0 ti: eb2e2000 task.ti: eb2e2000
[   10.820415] EIP: 0060:[<f8cfd68d>] EFLAGS: 0001087 CPU: 0
[   10.820454] EIP os at radeon sa_bo_new+0x36d/0x380 [radeon]
[   10.820476] EAX: f6840000 EBX: 00000100 ECX: eb2a3d00 EDX: f68410e4
[   10.820500] ESI: 00000003 EDI: f6840000 ESP: eb2e3c84 ESP: eb2e3bfc

...

[   10.821517] ---[ end trace bab71d61e448d30f ]---
error: unexpectedly disconnected form boot status daemon
[   12.295993] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[   12.617099] FAT-fs 9sdb1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[   13.839761] EXT4-fs (loop1): mounted ext3 file system using ext4 subsystem
[   13.861484] EXT4-fs (loop1): mounted filesystem, with ordered data mode. Opts: (null)
umount: can't umount /cdrom: Device or resource busy
umount: can't umount /cdrom: Device or resource busy
umount: can't umount /cdrom: Device or resource busy
Generating locales...
  en_US.UTF-8... up-to-date
Generation complete.
pwconv: failed to change the mode of /etc/passwd- to 0600
Using CD-ROM mount point /cdrom/
Identifying... [e75b7e243f3728fc60fa52b2bcd668e7-2]
Scanning disc for index files...
Found 2 package indexes, 0 source indexes, 0 translation indexes and 1 signatures
Found label 'Ubuntu 14.10 _Utopic_Unicorn - Release i386 (20141022.1)'
This disc is called:
'Ubuntu 14.10 _Utopic_Unicorn - Release i386 (20141022.1)'
Copying package lists...gpgv: Signature made Wed Oct 22 19:44:26 2014 UTC using DSA key ID FBB75451
gpgv: Good signature from 'Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>"
Reading Package Indexes... Done
Writing new source list
Source list entries for this disc are:
deb cdrom:[Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1)]/ utopic main restricted
Repeat this process for the rest of the CDs in your set.
[   27.346056] i2c_hid i2c-DLL0641:00: failed to retrieve report from device.
[   27.359761] i2c_hid i2c-DLL0641:00: failed to retrieve report from device.
[   27.363743] i2c_hid i2c-DLL0641:00: failed to retrieve report from device.
[   27.367655] i2c_hid i2c-DLL0641:00: failed to retrieve report from device.
[   27.623056] iwlwifi 0000:03:00.0: Unsupported splx structure

I manually restarted after waiting 5-10 minutes and recreated the USB drive. I rebooted with the same results (stopping at the same place).

I think the error on line seven (kernel BUG) is the root cause of the problem, but I could be wrong. Is there anyway to fix or work around this bug to successfully install Ubuntu?


I tried booting with both legacy and secure boot and both UEFI on and off. The same stick works perfectly fine on other computers.

If there is any more relevant info I might be leaving out, let me know.

0

Success!!! I found that I needed to disable fast startup on Windows for Ubuntu to successfully install.

Steps to disable fast startup:

  1. Go to start screen and search for "change what the power buttons do"
  2. Click "change settings that are currently available"
  3. Scroll down and uncheck "Turn on fast startup".

After fixing that, I did run into Ubuntu 14.04 LTS live USB boot error (gfxboot.c32:not a valid COM32R image), which had an easy workaround.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.