2

I am unable to open Google Chrome. I tried removing and installing it again. But this did not solve the problem. On trying this command google-chrome on terminal, it shows

shm_open() failed: Permission denied
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[8239:8239:0121/203748:ERROR:background_mode_manager_aura.cc(14)] Not implemented reached in virtual void BackgroundModeManager::EnableLaunchOnStartup(bool)
[8239:8239:0121/203748:ERROR:shared_memory_posix.cc(231)] Creating shared memory in /dev/shm/.com.google.Chrome.et02yU failed: Permission denied
[8239:8239:0121/203748:ERROR:shared_memory_posix.cc(234)] Unable to access(W_OK|X_OK) /dev/shm: Permission denied
[8239:8239:0121/203748:FATAL:shared_memory_posix.cc(236)] This is frequently caused by incorrect permissions on /dev/shm.  Try 'sudo chmod 1777 /dev/shm' to fix.
Aborted (core dumped)

Can anyone help me make Chrome work on my laptop.

  • did you get some errors by tring chromium ? or why you must use chrome ? – Duncan Wielk Jan 25 '15 at 23:17
1

Try sudo chmod 1777 /dev/shm to fix.

btw, it's the last thing that is said in the error output.

  • The problem remains every time I login to my system. Can there be a fix to it? – nomorequestions Jan 23 '15 at 18:36
0

To permanently fix this problem, mount /dev/shm with the proper flags, by putting the following in /etc/fstab:

none  /dev/shm    tmpfs   rw,nosuid,nodev,noexec    0    0

The previous change requires a reboot before they get effective.
To get the same effect without reboot, run the following command:

sudo mount none -t tmpfs -o rw,nosuid,nodev,noexec /dev/shm

If /dev/shm was already mounted, add the remount option:

sudo mount -o remount,rw,nosuid,nodev,noexec /dev/shm
  • It gives this error.. "mount: can't find /dev/shm in /etc/fstab or /etc/mtab" – nomorequestions Jan 27 '15 at 6:41
  • @nomorequestions Have you added /dev/shm to /etc/fstab as I suggested at the top of the answer? – Rob W Jan 27 '15 at 8:43
  • I don't get how to do it. Can you please give command to do that. You said to use sudo mount -o rw,nosuid,nodev,noexec /dev/shm is it to add /dev/shm to /etc/fstab? If so it gives the error as I mentioned previously. – nomorequestions Feb 1 '15 at 12:29
  • @nomorequestions Example: sudo nano /etc/fstab (or vim, or whatever favorite editor that you trust with root privileges). Then put the line from my answer in it and reboot. – Rob W Feb 1 '15 at 22:24
  • I added the line none /dev/shm tmpfs rw,nosuid,nodev,noexec 0 0 into /etc/fstab and rebooted.. But it did not solve the problem. – nomorequestions Feb 3 '15 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.