0

After a fresh 14.04.1 install I removed a few packages, disabled updates (because updating causes suspend/sleep not to work), ran apt-get update and apt-get upgrade (which of course printed 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.), and finally tried installing packages with apt-get, but I get this error message:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 clang-3.3 : Breaks: clang-3.4 but 1:3.4-1ubuntu3 is to be installed
 clang-3.4 : Breaks: clang-3.3 but 1:3.3-16ubuntu1 is to be installed
 clang-3.5 : Breaks: clang but 1:3.4-0ubuntu1 is to be installed
             Breaks: clang-3.3 but 1:3.3-16ubuntu1 is to be installed
             Breaks: clang-3.4 but 1:3.4-1ubuntu3 is to be installed
 clang-format-3.3 : Breaks: clang-format-3.4 but 1:3.4-1ubuntu3 is to be installed
 clang-format-3.4 : Breaks: clang-format-3.3 but 1:3.3-16ubuntu1 is to be installed
 clang-format-3.5 : Breaks: clang-format-3.3 but 1:3.3-16ubuntu1 is to be installed
 epiphany-browser : Depends: libwebkit2gtk-3.0-25 (>= 2.1.4) but it is not going to be installed
 libreoffice : Depends: libreoffice-base but it is not going to be installed
               Depends: libreoffice-core (= 1:4.2.3~rc3-0ubuntu2) but 1:4.2.4-0ubuntu2 is to be installed
               Depends: libreoffice-report-builder-bin but it is not going to be installed
 octave : Depends: default-jre-headless but it is not going to be installed
 openshot : Depends: gtk2-engines-pixbuf but it is not going to be installed
 python-clang-3.3 : Breaks: python-clang-3.4 but 1:3.4-1ubuntu3 is to be installed
 python-clang-3.4 : Breaks: python-clang-3.3 but 1:3.3-16ubuntu1 is to be installed
                    Breaks: python-clang-3.5 but 1:3.5~svn201651-1ubuntu1 is to be installed
 python-clang-3.5 : Breaks: python-clang-3.3 but 1:3.3-16ubuntu1 is to be installed
                    Breaks: python-clang-3.4 but 1:3.4-1ubuntu3 is to be installed
E: Unable to correct problems, you have held broken packages.

Both:

dpkg --get-selections | grep hold

And:

apt-mark showhold 

Return nothing.

I suspect this is caused by the disabled update sources. If yes, then why cannot apt-get just install the versions from release time? Why does it want newer versions?

Are the original packages removed from the repositories in case of security updates? Are only updated versions of dependencies available?

$ cat /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb cdrom:[Ubuntu 14.04.1 LTS _Trusty Tahr_ - Release i386 (20140722.2)]/ trusty main restricted
  • so my real question is: Are the original packages removed from the repo in case of security updates? Are only the updated versions available? – mlbaqynh Jan 21 '15 at 15:27
  • installations do work after updating, and now suspend seems to work too (maybe I had the unsupported updates enabled last time), but I am still curious about why I cannot install certain packages without updating – mlbaqynh Jan 21 '15 at 15:43
  • Did you disable the repositories as well? – user364819 Jan 21 '15 at 16:18
  • @Toroidal: the updates are repositories, see /etc/apt/sources.list – mlbaqynh Jan 21 '15 at 16:52
0

I don't know exactly what you did, but I'd guess that you're correct that your "the disabled update sources" broke everything. (And your software sources should have nothing to do with suspend/sleep... even updating has to be manually initiated, so again once it's finished it shouldn't affect suspend/sleep).
apt relies upon the software sources to know where & what to update/download/install, without proper reliable software sources it's crippled. You could try a sudo apt-get check for some info, but regardless you may need to restore them:

If you destroyed your software sources somehow, you can go to this site http://repogen.simplylinux.ch/ to create a new sources.list file. And/or follow the directions here for more info on backing up the current sources & having them automatically re-created or getting one from the above site.

If you don't want newer versions of packages, then you can just run the currently installed ones, though there could be security holes waiting to be patched, or improved updates waiting too.

0

You could try and run sudo apt-get dist-upgrade which does update more packages as the normal "upgrade" package would do.
Also a call to sudo apt-get check and sudo apt-get -f can't hurt.

  • $ sudo apt-get check Reading package lists... Done Building dependency tree Reading state information... Done – mlbaqynh Jan 21 '15 at 15:12
0

If you have disabled all repositories then this is the problem for the application which you are trying to install is from one of those repositories. So you would either need to activate them all, or find the specific one which this software uses and activate that one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.