I've just received a M6600 and tried to install Ubuntu 11.04 on the machine with some pretty poor results.

By default the Radeon driver is used for the graphics card however it appears to run very poorly (screen re-drawing visible, tearing of dialogs while moving them).

I installed, through Jockey, the fglrx driver (however I don't know the version that was installed) with even poorer results. All conditions were exacerbated, was almost impossible to use the machine because of tearing while moving windows and typing.

With radeon driver installed, I check with powertop and see that radeon module is 65% of my inturrupts and that I'm using 70w of power (only 1 hour of battery life).

I will check the fglrx module also, however its even more unusable.

Please, any help would be appreciated! I cannot find release notes for the fglrx modules to know if this card is supported.

  • It should be noted that under fedora there are better results, I'm however not huge fan of Unity or Gnome-Shell in their current states and would prefer to continue using Unity in Ubuntu until the next major revisions of each distribution. – Andrew Dunn Aug 18 '11 at 12:31
  • Hit enter too quickly. Under Fedora I strictly use the radeon module, checking powertop there is less usage however its still incredibly high (65w). By default the card seems to run 'snappier' under fedora inside gnome-shell. I did try to install the vendor supplied (Dell) driver (rpm) but there was no noticable difference in terms of graphics performance or power consumption. – Andrew Dunn Aug 18 '11 at 12:32
  • Welcome to AU, you should edit your question to add the information you've put in the comments, that'll bump your question. – Jorge Castro Aug 19 '11 at 22:03

I was using the default open-source drivers without any problems with my m6600 (with AMD FirePro M8900) until this morning - now everything is horribly slow/lagged. Not sure what's going on. I also had problems with fglrx so I don't think that is an option.

  • edit: I have some new, very interesting information.. it appears it was my GTK 2.0 theme selection that was causing all of my performance issues with the open source drivers. I was using a theme called "Adwaita Wolfe V4" and anytime I opened an app that used the GTK menus that's when performance crawled. As soon as I selected a different gtk theme with gnome-tweak-tool, things started working buttery smooth again. Hope this helps someone else out. It should be noted that I'm also seeing high powerdrain with powertop.. best I can do is ~68 watts by toggling all the tunables to 'good'.
  • Ubuntu 12.04 update: The open source drivers are still working quite well, but with compiz running and three monitors going simultaneously, general window management performance really begins to suffer after more than 3 applications are up and running. The launcher/dash is extremely unresponsive, and switching tabs in applications like chrome and pidgin is very sluggish. Dragging and re-sizing windows is especially slow as well. I tried fglrx again (catalyst 12.4), but was unsuccessful at setting up multiple monitors (Segfault after setting 'Virtual' under subsection display.) – tamale May 9 '12 at 14:57

for what i know there are 4 main things to consider:

  • the power management specifications like the ACPI are proprietary and the brands usually do not love to share those specs, this is the main reason why most people experience too much problems with power-related issues like a battery that act strange or a backlighted display that does not act properly.

  • if you do not read docs before doing everything you probably could try infinite combination without any results.

  • the fglrx package from the repository are tipically really outdated and it's not the best choice for performance

  • both the fglrx package from the repo and the official closed source driver that you can get from the AMD ATI website need some tuning as described here http://wiki.cchtml.com/index.php/Main_Page so it's simply not enough to install a deb package.


I have Ubuntu 10.04 generic PAE I used the below link to install video driver


Read the PDF because, at the end of the installation process , you must run aticonfig --initial

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.