On Machine A, I start Remmina (0.9.3) and create a VNC Incoming Connection profile. I picked port 5900, with a username and password. No changes under advanced or SSH. I start the profile and it says "Listening on port 5900 for an incoming VNCI connection..."

On Machine B, I start Remmina and create a VNC profile. I set machinea.local:5900 as the server, enter the username and password and leave everything else as-is. I start the profile and it says "Connecting to 'username@machinea'..."

Patience is a virtue, but half an hour later there's still nothing but those message windows.

So far I've:

  • Made sure UFW isn't enabled
  • Confirmed I can ping and ssh from Machine A to Machine B and vice versa
  • Tried on other ports
  • Tried without a username and password
  • Googled aimlessly
  • Made a cup of tea

What's next?

Further actions taken:

  • Confirmed I can successfully telnet machinea.local 5900 from Machine B (thanks Pavlos G.)
  • Run ifconfig on Machine A to get network IP address (10.0.0.x)
  • Attempt ping, telnet and Remmina using IP address instead of hostname
  • Confirm you're not trying to set up a reverse VNC connection
  • Confirm you're using not trying to using client software as a server (doh!)
  • Can you telnet to port 5900? Is it open? – Pavlos G. Aug 18 '11 at 13:03
  • @pavlosg yes, if I telnet machinea.local 5900 from Machine B I get a "Connected to machinea.local." message - I take it this is a more reliable test than pinging and ssh since it happens on the port in question? the problem remains but I've updated my list of actions! :) – lofidevops Aug 19 '11 at 5:34
  • Testing the specific application port is indeed more reliable. Have you tried to connect by an IP address or a hostname? – Pavlos G. Aug 19 '11 at 11:31
  • @pavlosg tried both, add IP address steps to my list troubleshooters? behaviour is the same using either hostname or IP address (after successfully telnetting in from Machine B, if I enter the escape character I get an empty warning box on Machine A and the incoming session is terminated) – lofidevops Aug 22 '11 at 12:45
  • @pavlosg more symptoms: if the listening server is running, the Machine B attempts to connect but never succeeds, if the listening server isn't running Machine B immediately says "Unable to connect" – lofidevops Aug 22 '11 at 13:01

It seems that the protocol option VNC - Incoming Connection is not what you expect.

Remmina's wiki page talks about reverse VNC connection support.

This means that it reverses the usual procedure of a client connecting to a server.
It's mainly used when firewall/NAT issues are involved.

So, remmina on machine A is waiting for a VNC server on machine B to connect to it.
Therefore, remmina is still the client-side of the connection, not the server-side.

I've made the following test in order to give you an example of how the whole thing works:

  • Created a new VNC - Incoming Connection to my linux box and started it.
    Now remmina is waiting for an incoming request from a VNC Server - not a VNC client

  • Started tightVNC server on my windows box and selected attach listening viewer and added the ip address and port of my linux box

  • Now my windows box is accessed remotely from remmina client.

| improve this answer | |
  • thanks! I hadn't realised Remmina didn't have a VNC server option – lofidevops Aug 23 '11 at 5:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.