1

I've upgraded to Gnome on my Ubuntu desktop, however I have to login in with tty and run startx, but when the computer sleeps, I have the gnome login screen and it doesn't accept my tty password... There is only one user and one password...

Is there a default password I can use?

  • Try changing the keyboard layouts. It should accept you user's TTY password, there is no default password as that would be pointless from a security point of view - the screen you see after suspend is probably the lock screen, which you could disable from Power & Privacy settings/uninstalling gnome-screensaver in old version of Gnome. – Wilf Jan 20 '15 at 18:29
  • I've tried disabling the lock screen using gnome extension caffeine it works but when I close my laptop for hibernation it doesn't accept my tty password which is only one basic letter!ni can't edit the privacy settings the button won't toggle its greyed out – Beginner Jan 20 '15 at 20:41
2

The quick answer is no, there is no default password.

However, it sounds like your keyboard settings for X differ from those setting for tty. Are you using a non-US keyboard, i.e. an AZERTY keyboard from example, or numbers in your password on a french keyboard? There are a couple of things you can try:

  • Look at the log files to see what the errors are being thrown up, when you try to log in to the gnome login;
  • Change your password to something where the keys are always the same on any keyboard layout, for example uiopkj;
  • copy your.xinitrc file to .xinitrc.bak, and delete all the lines in the original .xinitrc file. Run startx with the empty .xinitrc file. Now try to test your keyboard layout setup.

You probably just need to ensure that the keyboard layouts in tty and Xorg are the same. I've had this happen to me many a time, when I was a locale test engineer, using loads of different "foreign" keyboards. Most frustrating.

Hope that this helps.

| improve this answer | |
  • 1
    Shoot! Only just seen Wilf's comment. Sorry... – Greenonline Jan 20 '15 at 19:37
  • Thank you so much for your answer guys I'm not using a foreign keyboard and my password is only one letter.. – Beginner Jan 20 '15 at 20:38
  • Hmmm... That is most odd... You've got me stumped. If you find out what the issue is, I'd like to know the answer. Good luck :-) – Greenonline Jan 20 '15 at 20:54
  • 1
    @Beginner - having a one letter password is not a bright idea (telling the internet does not help as well). You can change your password a few times using passwd or user settings and see if any others work. It may be that GDM can't process very very short passwords or something like that. Some settings may not work properly unless started from logging in to GDM, so find a password that works with GDM first. – Wilf Jan 20 '15 at 23:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.