0

I just got a new Dell XPS15 whic has an Nvidia GeForce GT 750m card in it. After trying every variation of driver setup between Ubuntu 14.04 and Ubuntu 14.10, I finally have a "usable" system, but I'm not very happy with it... Everything is just slow compared to my old precision running 14.04 with an Nvidia card. (e.g. the mouse is jerky, switching workspaces is slow, etc)

However, the real problem and probably at the root of the other problems is the fact that my system doesn't seem to like my external monitor.

It works, but when I go into nvidia-settings, it doesn't show 2 monitors like I expected but instead only one as shown in this nvidia-settings image:

enter image description here

Also, when I go into the displays portion of system settings, it totally gets the primary and secondary displays mixed up, sort of.... it shows that the built-in is selected as the primary display, but it puts the top Gnome bar on the external display, and if I want to use workspaces, I have to allow workspaces on non-primary displays. see this image grabbed from my secondary display:

grabbed from my secondary display

I've tried everything and I'm not sure how it's possible to get this configured.

output of inxi -Gxx

:~$ inxi -Gxx
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:0416
       Card-2: NVIDIA GK107M [GeForce GT 750M] bus-ID: 02:00.0 chip-ID: 10de:0fe4
       Display Server: X.Org 1.16.0 drivers: nvidia,intel Resolution: 1920x1080@59.9hz, 1920x1200@60.0hz
       GLX Renderer: GeForce GT 750M/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 331.113 Direct Rendering: Yes

xorg.conf

Section "ServerLayout"
  Identifier "layout"
  Screen 0 "nvidia"
  Inactive "intel"
EndSection

Section "Device"
  Identifier "intel"
  Driver "intel"
  BusID "PCI:0@0:2:0"
  Option "AccelMethod" "SNA"
EndSection

Section "Screen"
  Identifier "intel"
  Device "intel"
EndSection

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
  BusID "PCI:2@0:0:0"
  Option "ConstrainCursor" "off"
EndSection

Section "Screen"
  Identifier "nvidia"
  Device "nvidia"
  Option "AllowEmptyInitialConfiguration" "on"
  Option "IgnoreDisplayDevices" "CRT"
EndSection
  • How technical are you? Do you know what a PPA is and what rolling software versions forwards and backwards is? – Fabby Jan 23 '15 at 1:02
0

You appear to be having a very similar issue to what I had with a Dell Alienware laptop. I posted a solution that worked for me here: Dual monitor setup, why does NVidia 340 Prime only detect one monitor?

  • It seems like the exact same issue. Problem is that if I use HDMI, the refresh rate for the built-in display is terrible and there's no way to change it which causes artifacting on the display and terribly "chunky" mouse movements. – Jonathan Doklovic Jan 28 '15 at 19:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.