0

I have tried to update all the packages in my ubuntu 14.04 system with the following commands:

  • apt-get update
  • apt-get install
  • apt-get upgrade

It took some time, downloaded and completed the process. When I checked I could see that my system still uses the old versions (simply I checked the Firefox and Chrome versions). So I have checked the package updates through 'software updater' and it showed update is available. I was able to update to the latest versions after updating through it. So my doubt is why the commands didn't work without showing any errors and how come this GUI method worked?

Thanks.

0

I assume you used all commands with sudo?
The sudo apt-get update command should first get new package lists from the servers you configured (default settings maybe).
The sudo apt-get install command always needs as a parameter the name of the package(s) to install, therefore it should do exactly... nothing!
Finally, the sudo apt-get upgrade command is responsible for actualizing your programs to the newest downloadable versions according to the lists you updated before.

So to solve your problem of some updates not being installed, please try sudo apt-get dist-upgrade, a more radical upgrade command which installs/replaces more packages.

If I could help you, please don't be shy and click the tick next to this answer to accept it, which will earn both of us some reputation and show the community that the question is solved. If it did not work, feel free to bother me again by leaving a comment. :D
Greetings!

  • Yes it worked very well. So I am not gonna bother you anymore :D – Gopu Jan 21 '15 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.