2

I am using following article to fix this issue: http://ubuntuforums.org/showthread.php?t=2246183

This is the output I get:

aditya@aditya-Vostro-3446:~/$ sudo apt-get purge wine
[sudo] password for aditya: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package wine is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 41 not upgraded.
aditya@aditya-Vostro-3446:~/$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done

0 upgraded, 0 newly installed, 0 to remove and 41 not upgraded.
aditya@aditya-Vostro-3446:~/$ 
aditya@aditya-Vostro-3446:~/$ sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.6 but it is not going to be installed or
                 wine1.7 but it is not going to be installed
E: Unable to correct problems, you have held broken packages. 

And when I try to install wine using ubuntu software center I get following message:

The following packages have unmet dependencies:

q4wine: Depends: libc6 (>= 2.14) but 2.15-0ubuntu10.9 is to be installed
        Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
        Depends: libqt4-dbus (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.8 is to be installed
        Depends: libqt4-network (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.8 is to be installed
        Depends: libqt4-sql (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.8 is to be installed
        Depends: libqt4-xml (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.8 is to be installed
        Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.1-0ubuntu4.8 is to be installed
        Depends: libqtgui4 (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.8 is to be installed
        Depends: libstdc++6 (>= 4.1.1) but 4.6.3-1ubuntu5 is to be installed
4
  • @karel please see this comment: askubuntu.com/questions/575706/… Do you still feel its a duplicate?
    – whizcreed
    Jan 20, 2015 at 10:00
  • Also try this one: Can't install wine on Ubuntu 14.04
    – karel
    Jan 20, 2015 at 10:30
  • 2
    0 upgraded, 0 newly installed, 0 to remove and 41 not upgraded. means that you have 41 upgrade pending. First try cleaning out packages you do not need sudo apt-get autoremove. Then update your system sudo apt-get update && sudo apt-get upgrade. If there still are some packages not installed, go with sudo apt-get dist-upgrade. Note, that this command will remove packages conflicting with the ones being installed, favouring more important ones. Try again sudo apt-get install wine.
    – julka
    Jan 20, 2015 at 12:15
  • The actual problem is: E: Unable to correct problems, you have held broken packages. I suggest you begin by following @julka advice in the comment above.
    – Elder Geek
    Jan 22, 2015 at 0:43

3 Answers 3

1

You can try one of the following:

sudo apt-get -f install

To force install the dependencies and such.

Or try installing it via the Ubuntu Wine Team PPA:

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.7
9
  • this is what i get in the end by using the ppa method: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: wine1.7 : Depends: wine1.7-i386 (= 1:1.7.18-0ubuntu1)
    – whizcreed
    Jan 20, 2015 at 9:59
  • What version of Ubuntu are you running AMD64 or i386? Or you can try to Install wine1.7-i386 then? like so: sudo apt-get install wine1.7-i386!
    – blade19899
    Jan 20, 2015 at 10:01
  • hmmm:: The following packages have unmet dependencies: wine1.7-i386:i386 : Depends: libgphoto2-2:i386 (>= 2.4.10.1) but it is not going to be installed Recommends: libfontconfig1:i386 but it is not going to be installed or libfontconfig:i386 Recommends: libsane:i386 but it is not going to be installed
    – whizcreed
    Jan 20, 2015 at 10:03
  • AMD64 or i386??
    – blade19899
    Jan 20, 2015 at 10:06
  • 1
    sudo apt-get install wine:i386? This issues is related to What happened to the ia32-libs package? and How do you run a 32-bit program on a 64-bit version of Ubuntu?
    – blade19899
    Jan 20, 2015 at 10:15
0

Try to install directly the last version:

sudo apt-get install wine1.7

or (previous version):

sudo apt-get install wine1.6
1
  • 1
    The following packages have unmet dependencies: wine1.6 : Depends: wine1.6-i386 (= 1:1.6.1-0ubuntu1~ppa1~precise1) E: Unable to correct problems, you have held broken packages. The following packages have unmet dependencies: wine1.7 : Depends: wine1.7-i386 (= 1:1.7.18-0ubuntu1) E: Unable to correct problems, you have held broken packages.
    – whizcreed
    Jan 20, 2015 at 9:51
-1

you need to reinstall package ttf-mscorefonts-installer because by default the license for this package is not accepted, you need to manually accept the license for this package."Microsoft's core fonts package has unmet dependencies in wine.

"first remove them from your system as

sudo apt-get remove ttf-mscorefonts-installer

then re-install

sudo apt-get install ttf-mscorefonts-installer

then accept the license using tab key in a graphical interface after doing this install any version of wine,you can install wine from software centre .This package is also required if you want to install adobe flash player plugin.Note: wine1.6.2 is the stable release and Wine 1.7.34 is the latest wine release as of now.You can refer to

wine HQ

Not the answer you're looking for? Browse other questions tagged or ask your own question.