I've been using Ubuntu for many years and have been quite happy with it the whole time. I have an Acer Aspire laptop with an AMD 6850M graphics card. On previous versions of Ubuntu, the proprietary drivers have worked perfectly fine, but since upgrading to 12.04 and then to 14.04 (64 bit for both), each time I try to install it via additional hardware or install the drivers using the latest beta or stable version following the instructions from cchtml Ubuntu will not boot as soon as I restart the laptop.

I've tried doing this on Ubuntu, Kubuntu and Linux Mint and have the same issue with all three distros. Has anyone experienced something like this before? If so, please help :)

  • same problem on an HP Envy 17-2090eb – tim Feb 12 '15 at 13:08

I have had problems in the past installing proprietary graphics drivers as none of the published guides seemed to work for me.

I eventually came up with a method that has worked for me on the last couple of versions of Ubuntu and on several different machines. I posted it the Ubuntu Forum (and it was later printed in Linux Format magazine).

  1. Boot up and when the black screen appears, press some of the cursor keys and a box appears with an X server error.

  2. Press CTRL + ALT + F1 to get a tty terminal.

  3. Log in as root. The password is your own password that you set during installation.

  4. Remove the Xorg drivers. apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon

  5. Reboot

  6. Repeat steps 1-3

  7. apt-get update

  8. apt-get install fglrx-amdcccle-updates

  9. aticonfig --initial

  10. Reboot.

| improve this answer | |
  • Hi Carl. Thanks for the link. I have two hard drives in this laptop so I can try on the second hard drive without breaking my current install. I'll let you know how it goes. – Richard Lam Jan 20 '15 at 10:06
  • Hi Carl. Just tried to do this but have failed. As soon as I reboot, the black screen comes up and I can't change to TTY2 or any other TTY. I rebooted again and followed the instructions to the T. Rebooted again and the black screen came back. – Richard Lam Jan 20 '15 at 12:02
  • You may have to hold down another key as well, depending on your laptop's keyboard, possibly Fn. – Carl H Jan 20 '15 at 13:06
  • I definitely used the right key combinations, though it didn't work at all. – Richard Lam Jan 20 '15 at 20:36
  • Please don't include just the link to an external site. Copy-paste the essential steps of the external answer into your question and then refer to the link as the source of the answer. Even when it's your own! ;-) – Fabby Jan 21 '15 at 9:42

After going through all possible solutions, I have checked the xorg log file and found a segfault when starting Ubuntu. Other users have exactly the same problem on launchpad. I don't think I can progress any further for this one unfortunately.

| improve this answer | |

Richard. I seem to have made it to a step beyond you on this issue. This problem seems most prevalent among users who have hybrid graphics: integrated Intel card for power conservation and an AMD card for performance. To get past this problem, I found a hacked version of my HP 2XXX series BIOS, by a guy named Donovan. The hacked version allowed me to choose muxed/muxless and fixed/dynamic in the BIOS.

By changing my BIOS to muxless dynamic (look it up if this terminology is new), I am running the fglrx-updates (proprietary) drivers. The laptop's screen was stuck on the highest brightness. You may need to find a solution for this. I found some instructions on editing some text in a settings document.

Lastly, and this is an issue I haven't overcome, in muxless dynamic mode, my Intel processor is supposed to function all the time. When the graphics gets too intensive, the extra load is supposed to be offloaded to the AMD card. Mine isn't working this way, though. Instead, I can load games like League of Legends (installed through Play on Linux & Wine). The load screens all work great and I can start a game. The moment the match starts and it attempts to go into full screen mode, everything disappears. So, the hybrid graphics situation stinks for people with AMD cards (mine has a Radeon HD 6850m). Good luck.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.