I have Ubuntu 14.04. I was using a HP Laserjet 6L which worked after strugling with it for several days. I now have HP LaserjetP1102w and I just cannot get it to print.

When I installed it the computer recognised it. I went to properties and tried to print test page but nothing happened. I rebooted computer but still nothing.

I looked at some other answers regarding similar problems but could not understand a lot of it.

Test this:

Open a terminal. CtrlAltT.

Run it:

sudo -i
apt-get update
apt-get install --reinstall hplip
hp-setup -i

Select the USB option from the list, and follow the prompts.

It will then ask about a propriatry plugin, let it download this , agree to the license then follow the rest of the prompts.

You left everything to default m for name of print queue, say y for the selected PPD being correct, put location to Home, and left additional information blank, then y to print a test page.

The printer should now work over USB.

Check the test page looks correct.

On the left side of the printer is a WiFi button, press it and it will create an Ad-Hoc WiFi network which you can connect to.

Connect to this using a suitable device, it will need a WiFi connection, either use your Gnu/Linux machine directly.

Once connected, find the IP Address of the printer by holding the red X button on the printer, which will make it print out a configuration sheet containing the IP Address.

Connect using a web browser to this IP address, and within the Network Settings, configure the connection to your actual WiFI network.

Check and double-check the settings are correct, then once saving the settings, it should try to connect to your WiFi network.

On your Gnu/Linux machine, remove the USB version of the printer within the System ---Administration---Printing menu, then run this command to run setup again:

sudo -i
hp-setup -i

Select the Network option from the list, have it download the plugin and accept the license again if asked, fill in the same prompts as above, and you should be ready to print over wireless.

  • Hi thanks for information but I am still having problems. I did "CtrlAltT" and opened terminal. At the top of it was christopher@christopher. What is "Run it"?. I tried to write sudo etc but I could not move down to second line. I looked up instructions on using terminal and it seemed like dos commands which I am familiar with but I could not manage it. – murphyc1 Jan 21 '15 at 22:13
  • Each line should be entered in, and then you press enter to execute what you've typed. For example, you start by entering sudo -i, the command to elevate yourself to root, and hit enter. Your prompt should then reflect that by changing christopher to root. Then simply repeat, entering each line and hitting enter. – Gary Apr 29 '15 at 2:11
  • I get an error here when downloading the plugin: "hplip-3.15.2-plugin.run file does not match its checksum. File may have been corrupted or altered" – MichaelChirico Dec 18 '15 at 19:40
  • For those who went over this quickly without doing sudo -i (like I did), for hp-setup -i to work you have to sudo. – Enrico Mar 15 '16 at 21:23
  • I found it necessary to specify the IP address of my printer in the final step. e.g. hp-setup -i 192.168.0.68 – mozz100 Nov 15 '16 at 22:16

I've run 'hp-setup' on a terminal and it worked for me. I've executed it without sudo. It opens a HP GUI for configuration. Just follow the intructions. Also, you can check the CUPS error log on http://localhost:631/

protected by Community Apr 22 '16 at 17:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.