2

I run Ubuntu 14.04. My CPU is Intel Core 2 Duo CPU P7450. It supports neither VT-x nor EPT. But it is 64bit.

I can only virtualize 32bit boxes with success. When I try 64bit i get a never-ending

default: Warning: Connection timeout. Retrying...

Tried to start the VM from GUI, and I took only this clue:

enter image description here

I pressed "Continue" and nothing happened but a black empty screen. Any solution? Why cannot I run 64bit VMs with a 64bit CPU???

4

The reason we can not run a 64-bit guest in Virtual Box even when run on a 64-bit host is that 64-bit guests don't make use of software virtualization. They depend on hardware virtualization to work:

VirtualBox's 64-bit guest support (added with version 2.0) and multiprocessing (SMP, added with version 3.0) both require hardware virtualization to be enabled.Virtual Box Manual

In case our CPU supports it we need to enable it in the BIOS of our computer:

In case our CPU does not support hardware virtualization we are unable to run 64-bit guests. We will still be able to install and run 32-bit guests.

0

I created a LAMP box to accommodate PC's that don't have VT-x or AMD-v visualization technology. It's currently in the Hashicorp catalog. just change the config.vm.box to teknology/rush-box-32bit.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.