1

I have a process (TRAIN) that turns and I have also started kdevelop and tried to build some application. Then it has frozen. Everything has frozen, no mouse, no changing desktop (Ctrl+Alt+arrow). I have also tried Alt+F2, or Ctrl+Alt+F1, but nothing happens. I have also tried the Alt+PrtScr and R+E+I+S+U+B, but nothing. I have a French keyboard that has no SysRq and Fx buttons are available when pressing Fn, it's very strange... Is there any other thing that I can try? I do not want to loose the process TRAIN that turns from 4 dais and is training an image classifier; it is almost finishing its job (one more day)... Thanks.

6
  • What about SSH? Can you use another PC to ssh into the system?
    – muru
    Jan 19, 2015 at 13:11
  • How to do that? :)
    – sop
    Jan 19, 2015 at 14:17
  • oh, that requires SSH to be already setup, which i assumed you had.
    – muru
    Jan 19, 2015 at 14:27
  • Can you give me a link of this stuff? It is not tellink me much... I used ssh for connecting to Amazon Instances, but I do not know how to connect to my machine :) I'll do it next time if I know how
    – sop
    Jan 19, 2015 at 15:07
  • Not that difficult: sudo apt-get install openssh - then you can do ssh IP-of-your-system from another PC on the same network.
    – muru
    Jan 19, 2015 at 15:08

3 Answers 3

2

If the DE has frozen, switch to a different run-level by using ctrl-alt-f3 and login to the terminal presented. You can kill any offending processes by using kill or killall, if the DE has gone into hardlock it may be worthwhile to kill xorg by sudo killall Xorg to restart the DE (usually drops you back to the DM to login),switch back to the graphic run-level with ctrl-alt-f7.

If you are unable to stop the offending process as described you can also try to enable ctrl-alt-backspace to kill the xserver without swapping run-levels, as a last-ditch effort to avoid a reboot on a hard hang.

As others have said, it may be worthwhile to pull the latest version of the software if the crashes are predictable and regular - indicating a bug (if it is not available on the repo, check ppa's or learn to install from source), however this may not always be possible so knowing how to recover a system without a hard reset is useful.

There are options available to restrict the ability for an application to crash the system, at the most basic you can attempt to run the offending process with nice to lower the priority so that attempts to lock down resources won't affect other processes. Depending on the exact sequence of calls leading to the crash there may be other ways to sandbox the application to avoid this repeating hang.

EDIT: Personally I use LXC for lightweight virtual sandboxes to keep development environments seperate from the base system, it may be helpful in your case to do the same, graphical applications use their own instance of Xorg and so crashes won't take down your host system, access to graphical output is easily achieved with xpra (and since the sandbox is running locally you have no latency issues with forwarding X over ssh). You may also see the answers to this question for other options on sandboxing

FURTHER THOUGHTS: If X has hung and is not responding to keyboard input (but the os itself hasn't crashed), you can also attempt to kill the process remotely via sshor other remote console system.

2
  • I have pressed also ctrl+alt+f3, but nothing has happend...I had no chance to ttry ctrl+alt+backspace so I cannot accept your answer now...
    – sop
    Jan 20, 2015 at 15:20
  • 1
    @sop If console switching is broken then the system is in a hard hang (either a full stall or kb input is being ignored = Xorg crash), if thats the case, its worth researching why the program is crashing or at the very least sandboxing it to avoid taking down the whole system. I will edit the answer to address basic sandboxing
    – crasic
    Jan 20, 2015 at 21:23
0

Open a System Monitor from Dash -> Go to 1st tab Processes. You can kill any process there, just right click on the process you want to kill and select kill process.

2
  • 2
    It looks like his entire system is halted and frozen - i don't think he can open the system monitor
    – Thomas Ward
    Jan 19, 2015 at 13:12
  • I have restart the machine...
    – sop
    Jan 19, 2015 at 14:16
0

If you know this process/program always crashes your computer (TRAIN or kdevelop or other), then you really should stop running it. Check for an updated version that might not crash everything, otherwise un-installing / removing it would be a good idea.

If you absolutely must run it, I'd suggest running Ubuntu in a VM (Virtual Machine, like VirtualBox) and run the unstable program/process inside of it. At least then when it crashes it should only freeze the VM and let your computer continue to operate.

And look into your SysRq key, should be available in case of emergencies next time.

3
  • 1
    The crash apparently occurred after starting kdevelop.
    – muru
    Jan 19, 2015 at 13:27
  • The crash was because of the build of some other app in kdevelop, so not the "TRAIN" process...
    – sop
    Jan 19, 2015 at 14:16
  • I was relying heavily on the title, "a process that I know it freezes my ubuntu?" and the user knowing which process was causing the crash. I'll edit my answer a bit
    – Xen2050
    Jan 20, 2015 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.