2

This question already has an answer here:

Setting up a new ubuntu server installation (14.04.1), I have been completely unable to get deluge to start as a daemon at system startup. Originally tried following this set of instructions: http://dev.deluge-torrent.org/wiki/UserGuide/Service/Upstart

I have tried / read countless questions and answers on stackexchange, as well as various other guides and posts by people having similar issues.

I am baffled to the point where I created an account on here to post, and see if I could get another set of eyes on this. I set this up once before on 14.04 running on a different system, and had no troubles at all.

On boot: not running, verified by ps -aux |grep delu Something I just noticed, when I enter sudo service d and attempt to use tab completion, "deluged" is not one of the available options, however if I type it in manually, sudo service deluged start returns deluged start/running, process 1475

Checking ps -aux |grep delu returns that is is running, however at 1482. The web-ui, which should have been started when the daemon was, is not however.

An immediate sudo service deluged status returns deluged stop/waiting rather than deluged start/running, process XXXX which it should be. However, checking ps -aux right after that shows deluged running with the perimeters from the upstart script.

Any other information that would help I am happy to provide. I attempted the solution from My command runs in bash, but not from /etc/init, what have I done wrong? but all it did was change to sudo service deluged startthe deluged starting/stopping message that they started with.

Unfortunately I am reusing the SSD I originally had it set up on in my new system, or I would look at how I had managed it there. I thought I might have used init.d rather than upstart, but I tried that as well, and it didn't work either.

$ cat deluged.conf    
description "Deluge daemon"

start on filesystem and static-network-up
stop on runlevel [016]

respawn
respawn limit 5 30

setuid deluge
setgid deluge
umask 007

exec /usr/bin/deluged -d

$ cat deluge-web.conf
description "Deluge Web UI"

start on started deluged
stop on stopping deluged

respawn
respawn limit 5 30

setui deluge
setgid deluge
umask 027

exec /usr/bin/deluge-web

marked as duplicate by muru, Eric Carvalho, Fabby, Elder Geek, BuZZ-dEE Jan 21 '15 at 19:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What if you manually run sudo -u deluge /usr/bin/deluge-web? – muru Jan 19 '15 at 18:17
  • Ok, actually, cleaning up the deluged.conf file and adding back in the -d tag worked, and it is now properly running / restarting, etc. Deluge-web however, is not starting, and attempting to start the service returns $ sudo service deluge-web start start: Unknown job: deluge-web – ken Jan 19 '15 at 18:22
  • that maybe because you have a typo - setui instead of setuid. I assumed it was a copying error. – muru Jan 19 '15 at 18:23
  • [ERROR ] 13:23:35 common:167 Unable to use default config directory, exiting... ([Errno 13] Permission denied: '/home/ken/.config/deluge') – ken Jan 19 '15 at 18:24
  • nope, I'm that big of an idiot. Must have snuck in when I was cleaning out env variables. – ken Jan 19 '15 at 18:25