0

I've had some struggles getting Java, Eclipse and Maven to work properly on my configuration.

environment:
Ubuntu 12.04
Java 8
Eclipse Indigo 3.7
Maven 3.0

Task: Install Maven plug in through Eclipse.
Question: Do you know which plug in works for my config?

Steps:
1) Installed Eclipse & Maven via Software center.
2) Following this AskUbuntu question "Install the Eclipse Marketplace" in step 4 the options below are presented:

1 -Maven Integration for Eclipse (Luna 4.4);
2- Maven (Java EE) Integration for Eclipse WTP (Luna 4.4);
3 -Maven Integration for Eclipse WTP (Juno 3.8/ 4.2)
4 -Maven Integration for Eclipse (Luna 4.4 and newer)

I'm not entirely clear on how plugins work; if I should be using the newest released plug in even if it's newer than my software version? Or the one closest to my Eclipse version?

Help please!

0

I took the plunge and tried "3 -Maven Integration for Eclipse WTP (Juno 3.8/ 4.2) "

and it worked. I'll circle back if any errors happen in relation to this plug in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.