0

I have the same problem as My computer boots to a black screen, what options do I have to fix it? and the solutions there did not help me fix it. I want to dual boot this to my Windows 8.1. I disabled fast and secure boot, when I restart my computer it does not detect the LiveDVD, I have to shift+restart for it to detect it, and when it does it shows me a black screen with three options (Try, Install, Check for Problems) and not the purple one where I can press F6 and solve my woes. When I press 'e' to edit the boot parameters, there are only three lines of parameters, the second one ending in quiet splash --. I tried adding nomodeset after the word splash then pressing F10 to boot with those configurations, and that did not work either. It's probably relevant information that I have two graphics cards: an integrated Intel(R) HD Graphics 4600, and a NVIDIA GeForce GTX 770M.

What should I do?

--EDIT:

Ok, so, I managed to install it, by deactivating UEFI and going through lengths and pains. Then I used a boot repair disk to make it possible to boot into Ubuntu, and all. Ok, so now I boot, and I get these options:

  • Ubuntu, with Linux 3.13.0-32-generic
  • Ubuntu, with Linux 3.13.0-32-generic (recovery mode)
  • Windows UEFI bootmgfw.efi
  • Windows Boot UEFI loader
  • EFI/boot/bootx64.efi
  • System setup

Choosing the 3rd or 4th option loads Windows normally, choosing the 5th causes me to load a weird power recovery thing, choosing the 1st loads a blank purple screen, and the 2nd loads a blank black screen. System setup loads the BIOS thing.

I expect, then, that I need to get the drivers to run ubuntu. What to do?

(Possibly relevant: http://paste.ubuntu.com/9784753/ the pastebin my boot recovery disk created.)

  • What one of the three options did you use? See this alot with Nvidia. When starts boot and shows keyboard icon on bottom, press key. Then do install, not try. This always worked for me. So basically what you posted, but skip the adding options. Just go right to install. Once installed you will need to probably need to use proprietary drivers. Just go to dash and search drivers once installed. – geoffmcc Jan 18 '15 at 20:57
  • Like I said, that screen does not appear. No purple screen with keyboard icon on bottom, just the black one with three options. – Pedro Carvalho Jan 18 '15 at 21:46
  • Right, but was one of those options was install, right. Did you try that instead of try. This is what I did when used Nvidia. When you restart you may get black screen, but then rather than choose first Ubuntu in grub use second. Then select failsafe graphics. This will get you into ubuntu so you can install proprietary Nvidia driver – geoffmcc Jan 18 '15 at 22:18
  • I just tried this, and it didn't work either. Still black screen, with or without 'nomodeset' set. – Pedro Carvalho Jan 19 '15 at 8:52
  • Now I deactivated the UEFI and after much suffering and crying I managed to install it. Now I need to find a way to boot it because I couldn't install the boot loader. I'm trying this: sourceforge.net/projects/boot-repair-cd – Pedro Carvalho Jan 19 '15 at 11:12
0

Go back into Ubuntu Recovery Mode. Look for an option "Drop to root shell prompt" and do that. By default it read only so we need to fix that

 mount -o remount,rw /

Now that we're mounted rw and in a root shell add ppa:xorg-edgers/ppa (assuming your card is in there - Source just scroll till you get to Nvidia drivers. If you find card, add ppa)

 sudo add-apt-repository ppa:xorg-edgers/ppa

And then

 sudo apt-get update

finally

 sudo apt-get install nvidia-verson#

Then restart

Also you can remove if needed by using

 sudo apt-get remove nvidia-version#

Ubuntu 12.04 does not support UEFI

My bad, it does

Edit 2

Because also get black screen in recovery, as suggested in comments - if you can get a livecd to boot using try ubuntu (think you said it worked after you disable UEFI) you can then mount your root partition and then add the ppa

  • I can't go into Ubuntu Recovery Mode, like I said. It just shows me a blank black screen when I choose that option. – Pedro Carvalho Jan 19 '15 at 16:41
  • I'm sorry I was no help. I'm bailing out since I don't have anything on me to try to duplicate the issue. Only other suggestion at this point is try a fresh install. – geoffmcc Jan 19 '15 at 16:42
  • "I should have read more carefully that your using 12.04, could have saved some time cause UEFI not supported in that version" Yeah, that version does in fact support UEFI, it's the first one that does. – Pedro Carvalho Jan 19 '15 at 16:44
  • Yeah I just noticed that and removed – geoffmcc Jan 19 '15 at 16:46
  • If only you could try ubuntu and get it to load. Then you could mount the root partition and then follow my answer. – geoffmcc Jan 19 '15 at 16:53
0

I have managed to do it.

I formatted the partitions I'd dedicated to ubuntu, then activated Secure Boot again, at which point my computer started detecting the LiveUSB I'd started using even with UEFI activated. I was still getting a black screen, but the fact that it flashed me a view of the desktop before going black suggested that all was not lost. I removed quiet splash and added nomodeset to the configurations, et voilà, I could install it.

After finishing the installation, I restarted my computer, went to the UEFI menu to change the boot priority, and successfully booted into ubuntu, though no grub menu with the list of operational systems showed up.

Still, victory! It works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.