23

I use Virtualbox 4.3.20 with Ubuntu 14.01 image. Host OS is Windows 8.1. Bidirectional drag'n drop used to work before but now it won't after upgrading to these versions from previous versions. What can I do to resolve the problem?

  • 4
    execute the command: sudo apt-get update && sudo apt-get install -y virtualbox-guest-* && reboot to install the guest additions. – blkpws Feb 17 '15 at 1:30
18

"Drag and Drop" was introduced with the guest additions in Virtual Box 5.0. with some limitations:

At the moment drag and drop is implemented for Windows- and X-Windows-based systems, both, on host and guest side. As X-Windows sports different drag and drop protocols only the most used one, XDND, is supported for now.VirtualBox Manual

In addition to that only drag & drop of simple text, or files and directories of the file manager not running with administrative permissions is supported.

Preliminary experimental versions of Virtual Box "Drag'N'Drop" to a Linux guest only were introduced in version 4.2 .

  • That's interesting because it did work before I upgraded using older versions of the software. – Niklas Rosencrantz Jan 19 '15 at 11:59
  • @NiklasRosencrantz: yeah - it really confused me when reading but all I can say is that I never got it to work properly on my systems. – Takkat Jan 19 '15 at 12:10
  • 1
    @Hi-Angel: thanks for the notice, see edit. However I would not call it fully implemented but it sort of works (sometimes) now. – Takkat May 29 '16 at 6:38
  • 1
    We are now several years later and it is not working on Win 10, VirtualBox 5.2, Ubuntu 18 for me – Colin D Sep 14 '18 at 15:49
  • @ColinD It works from Ubuntu to Windows 10 for me. But not the other way round. It may be a limitation from Windows. – Takkat Sep 14 '18 at 17:27
5

According to the Release notes: https://www.virtualbox.org/wiki/Changelog-4.2

"Added experimental support for Drag'n'drop from the host to Linux guests. Support for more guests and for guest-to-host is planned."

I did not see any newer release notes indicating that status had changed.

So, Drag 'n' Drop will only work 1 way. Try enabling only "host to guest". Also, because of this reason it may be more efficient to just use a shared folder and move files back and forth that way.

  • The shared folder is an effective approach. I do this as well. – Elder Geek Feb 17 '15 at 14:49
3

Have you done

sudo apt-get install virtualbox-guest-dkms

to ensure that virtualbox doesn't break after kernel updates?

  • Yes, I tried that and tested again. Drag'n drop didn't work. I also tried changing to guest-to-host drag'n drop and that didn't work either. I'm dragging with the left mouse button and the file just won't come over the edge of the VirtualBox window. Thanks anyhow for the answer. – Niklas Rosencrantz Jan 18 '15 at 15:13
  • 1
    We should not recommend to install out-dated guest additions from the repositories to a newer Virtual Box release. – Takkat Jan 18 '15 at 15:38
1

I solved this problem with a "dirty" way. I just compress any files/folder i want to DnD from my ubuntu VM to windows to .zip format. Hope that helps.

0

You can try one more thing 1)share desired folder from windows OS. 2) Check Network adapter is on NAT connection. 3) from ubuntu on files select connect to server. 4) smb:/// 5) Enter username and password of windows user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.