7

My brightness controls weren't working before, but I didn't really care, but somehow I lowered my screen brightness while downloading league through playonlinux. Now the brightness controls aren't working with the FN keys or in the settings, and its stuck on very low.

I tried this http://itsfoss.com/fix-brightness-ubuntu-1310/, and everything here https://sites.google.com/site/easylinuxtipsproject/display, but they didn't do anything.

I am on a Lenovo Z500 using Intel graphics. I have a Nvidia GeForce GT 635M but don't use it.

I have noticed that there are the folders ideapad, intel_backlight and thinkpad_screen in /sys/class/backlight/, each with the files actual_brightness, brightness, and max_brightness. Only in intel_backlight is actual_brightness set to the maximum value. It says, though, that I don't have the permissions to change them with sudo.


Workaround: I got brightness back up by using the brightness FN keys outside of Ubuntu (before it starts or in the BIOS settings), but still whenever I press either of the brightness buttons it goes really dim and cannot be changed.

  • 1
    xbacklight -set 100 should work – kenn Jan 18 '15 at 11:51
  • no, i've tried that, it doesn't do anything – Toby Jan 18 '15 at 12:16
  • 1
    I you found the answer yourself, then please post your solution as an answer and mark it as accepted. – LiveWireBT Feb 18 '15 at 11:18
  • you can try this . xrandr --output LVDS1 --brightness 0.8 – BKS Sep 2 '15 at 23:15
  • 1
    @neoFox It doesn't change the actual brightness. – frogatto Dec 10 '16 at 6:17
9

Two years ago I bought this laptop which works pretty well with Linux. When I upgraded to my new distro, Elementary OS Freya, I noticed the problem that backlight was unable to change. I could change it only on grub screen. After trying every guide on the internet I partially solved the issue by downgrading the kernel (and the related Intel graphics driver) to version 3.13. Yesterday I gave another try. It was very lucky :)

Here the solution:

On the grub configuration file /etc/default/grub modify the following line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

by adding this string: acpi_backlight=vendor.

In my case it is:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Update grub by launching:

sudo update-grub

Then create a xorg configuration file like this:

/usr/share/X11/xorg.conf.d/80-backlight.conf

and copy in it this text:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"     "sna"
    Option      "Backlight"       "ideapad"
    BusID       "PCI:0:2:0"
EndSection

Save the file, Reboot, Enjoy :-)

This trick could work on other Lenovo Ideapad laptops. I tested on Lenovo Ideapad z500 on Elementary OS Freya and Debian 8 Jessie.

If you have complitely another laptop you can try this way: Modify grub like in the first part of the guide, update grub, reboot, then verify what backlight "drivers" (I don't know what they are) are being listed. Give:

ls /sys/class/backlight/

and if it gives:

backlight_driver1
backlight_driver2
backlight_driver3

Then create the xorg file with one of the drivers in the list:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"     "sna"
    Option      "Backlight"       "backlight_driver1"
    BusID       "PCI:0:2:0"
EndSection

And reboot. If it works, enjoy, otherwise modify the file with another one in the list the same way.

  • On some laptops the first step is enough to fix it. – Błażej Michalik Jan 23 '18 at 0:26
  • While this answer provides a solution, it doesn't provide for a way of setting upper and lower limits on the brightness. (Pushing the brightness up too high results in the brightness dropping down to its lowest limit again, probably due to an overflow of some kind.) – Agi Hammerthief Dec 17 '18 at 8:17
  • Grub + 80-backlight.conf have worked for me. I've created 20-intel.conf using other guides before, so to make it work need delete this file, staying with 80-backlight.conf only. (Lenovo Z500). – egorlitvinenko Mar 7 at 21:08
  • works great on ubuntu 18.04 – Yashar Mar 20 at 19:38
1

You could try this

  1. Add GRUB_CMDLINE_LINUX="acpi_backlight=vendor" to /etc/default/grub.
  2. Update grub and reboot. Execute sudo update-grub && reboot.
  • Nope, nothing changed. – Toby Jan 18 '15 at 11:15

protected by Community Aug 24 '16 at 22:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.