4

In Firefox 35, there is menu called "Apps" that allows to install "firefox apps" through Firefox Marketplace. I installed an app but now I can't find how to remove it! Is there an obvious way that I cannot see?

I am using Ubuntu 14.04.

| improve this question | | | | |
  • In the apps screen you can long press on installed apps to uninstall them. – Hany Alsamman Jan 17 '15 at 19:04
  • 1
    I don't understand, I tried long-pressing at various places but nothing happened. Which is actually the "apps screen"? I use a laptop with a mouse if this is of any relation. I accidentally found another way, although it is not through Marketplace... – MakisH Jan 17 '15 at 19:15
4

To uninstall Firefox marketplace apps from your system, you should go to Home directory and unhide all content by pressing Ctrl+H. Then, navigate to the file/folder and copy the file name, after that open the terminal by pressing Ctrl+Alt+T and run following command (replace the .appname-hash with the original application).

Where appname is a recognizable descriptor for the app, and hash is an arbitrary string of characters. On my Linux machine, this Rechargeall app installs to ~/.rechargeall-2d7d25496791e76f039bfc4bcd24ca7a.

~/.appname-hash/webapprt-stub -remove

For example:

~/.rechargeall-2d7d25496791e76f039bfc4bcd24ca7a/webapprt-stub -remove
| improve this answer | | | | |
  • I can't check this anymore, since the whole Firefox Apps concept seems to be abandoned. However, this seems to be the most portable solution so I mark it as "answered". All the other solutions look also good for Ubuntu in particular. Thank you all for the help! – MakisH Sep 27 '16 at 14:33
8

I found a way: when an app is running, right-click on its unity launcher icon and select "Uninstall app".

But there should also be a way through Firefox Marketplace...

| improve this answer | | | | |
  • happy you found a way to get out of this – Hany Alsamman Jan 17 '15 at 19:21
  • I tried Firefox Marketplace app on Ubuntu 11.04 with Gnome2 classic, and there is no unity launcher icon added there, unfortunately... – sdaau Jan 21 '15 at 3:10
1
  1. Remove desktop file ~/.local/share/applications/appname.desktop
  2. Remove recursively ~/.appname/ directory

Example with connectA2:

rm ~/.local/share/applications/owa-connecta2-8f4c5ac47d5e07bd4a1598695aa3e05b.desktop

rm -rf .connecta2-8f4c5ac47d5e07bd4a1598695aa3e05b/
| improve this answer | | | | |
1

Actually, in this case the application behaves like an OS application. Though it is installed by Firefox. So don't look for the application in the Firefox browser. It may seem a bit annoying to run the application first in order to uninstall that from system !!! But this method works. You can follow the steps below (I was using Ubuntu 14.04 with Unity DE):

  1. Click on the Ubuntu logo from the top of left bar for the Dash
  2. Type the application name you want to uninstall.
  3. When the application icon shows in the search result, click to open it.
  4. After opening the application, left click on the icon from the left bar (launcher) and click "Uninstall this application".
  5. A notification will pop up at the right-top corner about the successful removal of the application.
| improve this answer | | | | |
  • 1
    tuxtu, This method actually worked without requiring commands. It's a bit counter-intuitive having to launch the app in order to uninstall it, so you should probably mention this. The only thing I would change is 4. The left bar is called 'the launcher' – rods Oct 1 '15 at 13:15
  • Thanks for your comment. I'm doing the necessary changes now. :) – tuxtu Oct 1 '15 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.