I am using 64 bit version of Ubuntu 11.04, under Ubuntu Classic, using ATI proprietary driver 11.5.

I had absolutely no issue with previous versions of Firefox, until I did an upgrade, and the entire window of Firefox stops rendering properly, as seen in screen cap below.

Basically besides the window control bar on top, everything else seems to be double rendered and one of the render is miss aligning the Y axis. Am I the only one seeing this? And how do I fix it?

Firefox 6 render problem

  • I didn't see a rendering problem but every so often FF6 would go into a memory hogging spree and thrash my system completely. Three reboots so far. – HRJ Aug 18 '11 at 2:54
  • the default Natty firefox is Firefox 4, is there a way to revert to Firefox 5 then? – hansioux Aug 18 '11 at 3:23
  • I got information regarding to possible hardware acceleration issue. I will attempt to fix this issue by two ways. 1. Turn off hardware acceleration to see if the issue is fixed. 2. reenable hardware acceleration and upgrade my ATI driver to 11.8 to see if the problem is resolved. I'll report back later. – hansioux Aug 18 '11 at 12:17

Thanks to cor-el on support.mozilla.com

To disable hardware acceleration.

Edit > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available" 

So the issue is hardware acceleration. And it only happens to my ATI card. My other computer running nVidia is working just fine with Firefox 6.

I tried to upgrade the driver to ATI 11.8, but I am not sure if it worked, and i am too tired to find out. Anyway, this at most is a workaround. There is some kind of bug either in the ATI driver or the way firefox hardware acceleration handles ATI drivers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.