0

Ubuntu 14.04 LTS.

After rebooting my machine following a hang by the Software Updater (updates appeared not to have been installed, but subsequently have been), the system font is appearing wrong (too small, borderline unreadable) in my main user account. It appears correctly if I log in as Guest.

The font is wrong in all window titles, Chromium tab headers and code editor in Eclipse. Haven't tried anything else.

I notice also that I cannot resize the icons in "my" account. They are stuck at what looks like 0.625 (the size I had them before). Resizing them from System Settings -> Screen Display works fine in the Guest account but does nothing in "my" account. This is not a problem for me, they're the size I want them, but possibly provides extra information.

I have downloaded the "GNOME Tweak Tool" and the fonts/sizes it lists are all identical for "my" account and the Guest account. Changing the size of the "Window titles" font has the expected effect in the Guest account, but no affect in "my" account.

Logging out and rebooting do not help.

Guest vs my account font sizes

  • You never accepted below answer while it got 2 upvotes in the mean time... Was there ever something wrong with it? – Fabby Apr 20 '16 at 10:56
  • Thanks for the answer and I'm glad it has apparently helped others. It was some good lateral thinking, though I was looking for a way to understand and resolve the underlying, rather than nuking the account and creating a new one. – Mark Smith Apr 21 '16 at 8:23
  • Do you still have this problem? Because doing a grep --ignoce-case font ~ > /tmp/$USER.txt in your guest and normal account and then doing a diff would get you to the bottom of this... – Fabby Apr 21 '16 at 15:08
  • Thanks, but no I don't. I got a new machine shortly after this. – Mark Smith Apr 21 '16 at 21:39
0

As your current user settings seem to be corrupted, and the guest account is not affected, do the following:

Go to system settings - User accounts create an additional user (let's call it "User2") with the same privileges as your current user.

Now, log out of the "bad" session and log in as "user2" and come back here to this site.

Everything is fine? Well then you should "accept" this answer as valid by clicking on the little grey check-mark below the "0" to the left of this answer and the next person asking the same kind of question will be able to use it as well.

Done? OK?

Now,

  1. open the file manager
  2. browse to the /home/user directory
  3. copy (not move!) all the files from Downloads to /home/user2/Downloads
  4. check you did a good job.
  5. Now delete /home/user/Downloads
  6. Go back to step 3 and repeat for Documents, Videos, ...

Done!

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.