5

I used the instructions on this site:

https://www.howtoforge.com/how-to-install-vnc-server-on-ubuntu-14.04

to install VNC server on my Ubuntu 14.04. It worked fine. I could login using VNC Viewer 5.1.1 from Windows. Today I did apt-get upgrade and restarted. After restarting the machine, I could not login either using VNC (Connection Refused 10061) or on the console. syslog showed a problem reading ~/.ICEauthority so I chowned that and now can login on the console but VNC still gives 'Connection refused.'

When I try to start vncviewer from a shell, I get:

Wrong type or access mode of /home/jjen009/.vnc.

jj

  • PS - when I try to start vncserver from a shell login, I get:Wrong type or access mode of /home/jjen009/.vnc. – John Jensen Jan 17 '15 at 0:18
  • So what are the type and access mode? Please add the output of ls -ld ~/.vnc/ to your post (also can you clarify whether you are trying to start vncviewer as per your question or vncserver as indicated in your comment). – steeldriver Jan 17 '15 at 4:17
  • I'm not sure what you mean by 'type' and 'access mode.' ls -ld ./.vnc: drwxrwxr-x 2 jjen009 jjen009 4096 Jan 17 14:16 .vnc I'm trying to start vncviewer from Windows to talk to the Ubuntu machine. Worked until I rebooted. jj – John Jensen Jan 18 '15 at 6:44
  • Have you verified (using ps - or netstat) that the VNC service actually started? – steeldriver Jan 18 '15 at 19:50
  • This blog describes how to set up rdp: c-nergy.be/blog/?p=8952&cpage=4 . The key to getting it to work on Ubuntu 16 and above is to install an alternative desktop environment. – Nathan Jones Jun 1 '19 at 18:00
4

There is a known bug https://bugs.launchpad.net/ubuntu/+source/vnc4/+bug/1200451 This means that even a super use can't start vnc if the relevant configuration files are owned by a regular user. Check with ls -la . on the home directory e.g. in my case:

ls -la .
drwxr-xr-x  2 wf   users      4096 Nov 10 10:57 .vnc

when I went out of super use mode i could run:

vncserver

to get:

New 'X' desktop is capri:1

Starting applications specified in /home/wf/.vnc/xstartup
Log file is /home/wf/.vnc/capri:1.log
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.