I'm new to Linux and recently switched to Ubuntu 11.04 due to my project requirement. My laptop has been freezing and going to black screen of death when I run anything related to display (Share desktop, stream video, etc). Today I went through the Ubuntu forum to install the appropriate graphic driver and, after doing it, I rebooted my PC. It gave an error before login saying "select the recovery mode" and after clicking OK, it didn't give the same error on reboot but I've lost the 11.04 graphical interface and all I see is the interface of Ubuntu v10 with slow visuals (even scrolling up/down on browser is really slow). For the reference, here's a desktop screenshot so that you can understand the situation. Also the laptop is overheating.

How can I fix this problem? How can i get the Ubuntu 11.04 view back?
I also tried Google, but couldn't find any issue like this.

Some general Information:

  • Laptop: HP TouchSmart TX2-1160ea
  • Processor: AMD Turion TX2
  • Memory: 4GB
  • OS: Ubuntu 11.04

Some debugging information::

$ report-hw | grep controller  

lspci -knn: 00:11.0 SATA controller [0106]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391]
lspci -knn: 00:14.3 ISA bridge [0601]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller [1002:439d]
lspci -knn: 01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics] [1002:9612]
lspci -knn: 08:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
lspci -knn: 09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 02)


$ dpkg -l '*fglrx*'

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
ii  fglrx          2:8.840-0ubunt Video driver for the ATI graphics accelerato
ii  fglrx-amdcccle 2:8.840-0ubunt Catalyst Control Center for the ATI graphics
un  fglrx-control  <none>         (no description available)
un  fglrx-control- <none>         (no description available)
ii  fglrx-dev      2:8.840-0ubunt Video driver for the ATI graphics accelerato
un  fglrx-driver   <none>         (no description available)
un  fglrx-driver-d <none>         (no description available)
un  fglrx-kernel-s <none>         (no description available)
un  fglrx-modalias <none>         (no description available)
un  xfree86-driver <none>         (no description available)
un  xfree86-driver <none>         (no description available)
un  xorg-driver-fg <none>         (no description available)
un  xorg-driver-fg <none>         (no description available)

If you need any more information that could help, just ask.

  • Hmm. Why didn't I think about this. hah. Thanks for switching my light ON. May be because that forum caused me this problem and I trust meta stack, i came here instead of going anywhere else.
    – Sam Scar
    Aug 17, 2011 at 11:57

1 Answer 1


I had similar problems with my video card ATI/AMD Radeon HD6470M. Look through this source and follow an instruction how to install proprietary driver Catalyst/fglrx
Hope it will help to solve an issue

  • :- I tried the given link, doesn't seems to make any difference. give the same output on 'dpkg' run as above. Also, the UI stays like Ubuntu v10. Moreover, at this point of time, i can't reinstall the OS as i'm half way project. Any help on this?
    – Sam
    Aug 18, 2011 at 8:05
  • Did you remove previously attempted installing FGLRX/Catalyst as mentioned in "Removing the Driver" section before new installation ?
    – Justas
    Aug 18, 2011 at 9:57
  • Hi,Yes i did. Then installed. no go.
    – Sam
    Aug 18, 2011 at 13:27
  • your desktop screenshot looks like you login as Classic Gnome Desktop. Try to login in Unity - you've got this choice when login screen appears (in the bottom) and see if something changes
    – Justas
    Aug 18, 2011 at 15:21
  • if nothing changed, then the easiest way how to repair everything - reinstall OS :) You could back-up all your home directory and also applications settings (most of them). Here you can find a comparision of back-up tools : askubuntu.com/questions/2596/comparison-of-backup-tools I like Deja Dup and Back in Time.
    – Justas
    Aug 18, 2011 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.