0

i just upgraded my PC from Ubuntu 12 to Ubuntu 14.04 (format and clean install) on a Kingston 60Gb SSD. I have a second hard disc fitted, a 1Tb standard disk that I use for data and backups (separate partitions). There are just two users, myself as administrator and my wife as a custom user. I log on with a password, my wife with none.

We are both members of the group "dad" which has Read Write permissions to the shared data partition, the owner of which is me. I can access the disk freely, whereas when logged on as my wife I cannot? It shows in Nautilus but returns "You do not have permissions to access" or similar.

In Ubuntu 8,9 10 & 12 all this worked easily, but suddenly doing what I'd always done to enable shared access is not working. What do I need to do in Ubuntu 14.04 to enable this simple activity?

1

Thanks for response:- Disk is mounted as /media/dad/Data which is /dev/sdb6

I tried the chgrp & chmod commands you suggested, logged out & logged in as my wife then tried to access "Data" - which shows up on her Unity launcher panel. It required the superuser password, which I entered , then access was available. However, when I then logged back in as me access was denied!

If I unmount it logged in as my wife , I can then access it logged in as me, so it seems accessible only to the first to mount the drive.

When I upgraded, I disconnected the 1 Tb HDD & booted from a 14.04 USB stick I had created from the ISO file. I opted to use all the SDD for installation & everything went well. Trusty installed & updated etc etc. Then I shut down, reconnected the HDD & everything looked fine – the partitions on the HDD appeared to me, access to them was allowed. Created a second user for my wife & then found no access to the HDD for her & I'm still stuck!

The HDD is partitioned into three – firstly a partition sdb1 with Trusty installed (which doesn't feature as part of the grub for the SDD as it was disconnected on installation to SDD). I can boot up to this if necessary using my PC's Winfast bootup menu. Secondly it has the Data partition as sdb6, a backup partition as sdb3 it also has a swap partition sdb5.

Previously I've had no problems e.g. for a couple of years with Precise, everything was working fine, even my shared folders were available on our home network to the daughter's windows laptop (home network is another problem area, but that's for another post!), data disk was freely available to both wife & me etc.

0

Assuming your disk is mounted as /media/user/disk.

And that is according fdisk /dev/sdb

And your partition is /dev/sdb1

Test this:

Open a terminal,

Press Ctrl+Alt+T

Run it:

sudo -i
umount /dev/sdb1
chgrp -Rf dad /media/user/disk
chmod -Rf 777 /media/user/disk
0

None of the suggestions I found searching on here, all along the lines of changing ownership & permissions worked. What I did was to make another directory in /media for Data i.e.

/media/Data (instead of /media/dad/Data)

Then I made an entry in fstab to mount the UUID of the relevant disk to /media/Data

logged out & hey presto! Access to both me & the second user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.