1

In my system with Ubuntu 14.04 system, I've recognized that my keyboard layout changes after I log in. Normally I use only Turkish keyboard layout, I can use it during login screen appears but after that it turns back to English layout even regarding indicator shows "Tr", regarding to Turkish.

Each time I have to;

  • remove Turkish layout
  • add English layout (temporarily)
  • add Turkish layout again
  • remove English one

Could you tell me how can I fix it, what's the reason of the issue?

  • 1
    Next time, leave the EN layout where it is and log out after setting TR as default. (are you running your UI in English?) – Fabby Jan 17 '15 at 21:32
  • @Fabby For now, I'm doing sth like you said, I now have two layouts for possible error. (UI lang is English of course) – ekremkaraca Jan 18 '15 at 8:44
  • So what happens after you log out and back in without deleting? Is the English keyboard the default or the Turkish? – Fabby Jan 18 '15 at 10:56
  • @Fabby Turkish layout is default, additional layout makes it fixed temporarily but it should be done without that. – ekremkaraca Jan 21 '15 at 13:39
  • Please keep it that way until we've gone to the bottom of this. What's the output of set | grep ^L[A,C] and the settings for system settings - language support - language (list all black ones) and if you're around, go to chat, Ubuntu General room and shout for me there! ` – Fabby Jan 21 '15 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.