A very similar question has been asked before by robazefa, but no one answered it. For the last month or so, my Ubuntu 14.04 LTS box has been been unable to open a couple of folders shared from external drives on a PC running Win 8.1 on a home network.

Through Files on the Unity desktop, I can browse the network, access the workgoup, access the Win 8.1 box, see and access its shares except the folders on its external drives. They appear on the list and I could access them without a problem a couple of months ago, but now I get a dialogue box with Unable to access location - failed to mount Windows share: Invalid argument message, with only the option to click OK.

These folders are readily accessible now from other Win 7 and 8 PCs on the network, but the same Invalid argument error now appears on the only other Linux box on the network which runs Mint Cinnamon.

My question is which argument is in invalid and how can I validate it?

  • I had this start happening "suddenly" too. I wonder which of the Linux updates broke things...
    – Kev
    Feb 26, 2015 at 13:45
  • 1st attempt: You get this notice when Windows system's firewalling does not allow remote file accessing.
    – Rinzwind
    May 6, 2015 at 11:53
  • 2nd attempt: please tell us the filesystems these are on and check if your system supports it (exFat might need installing a driver).
    – Rinzwind
    May 6, 2015 at 11:55

7 Answers 7


I resolved this by using the IP address instead of the server name.

  • and how did you obtain the IP address? ... How wuold you get it if you only know the server name?
    – S.A.
    Apr 18, 2018 at 15:27
  • 2
    @S.A.Ping the server name.
    – Cereal
    Apr 18, 2018 at 16:16
  • Walk over to the windows computer, open up Command Prompt, and type in ipconfig. Aug 31, 2021 at 7:39

This sounds like a regression. An Ubuntu bug report and upstream bug report has already been made for it. It might be best to set yourself as "affected" and ask what information is needed. also clearly state that this is a regression. Regressions get fixed faster.

Workaround #1

You can try manually opening the share with nautilus (the file manager)

nautilus smb://ServernameOrIp

Workaround #2

You can try mounting it with smbclient. Example:

smbclient –L geekmini –U geek

Where geekmini is pc and geek is username.

Create mountpoint:

sudo mkdir /media/Video

Actually mounting the drive:

mount –t cifs –o username=geek,password=thepass //geekmini/root /media/Video

edit /etc/samba/smb.conf

and Disable SMBv1 and use SMBv2 works for me

like min protocol = SMB2

  • This didn't work on Ubuntu 22.
    – Raleigh L.
    Aug 11, 2022 at 4:48

My samba share has started to produce this same error after the group the shared directory had, and was shared to, has been erroneously deleted.

It got back to work OK after the situation with the disappeared group was resolved.

One could resolve it giving the share another group in the smb.conf file, but I just recreated it on the system level.

Hope this will help.

  • This is what worked for me. I had forgotten that I have created a group for samba users. Thanks!!!
    – Sileria
    Oct 7, 2021 at 18:41

Same issues here -- although I found out that in win 8.1 introduced STORAGE SPACES into windows, allowing the clustering of hard drives into combined resources -- I have 8 drives of 4tb functioning as a single 32TB drive array.

I got mine to work by adding the option -o vers=3.0 to my mount command and that solved my invalid argument error.

Hope that helps your situation.

  • Sorry, I should have posted earlier. Nothing I tried worked when I first encountered the problem. A couple of months ago, I found a workaround by accident. Cleaning up, I unplugged all the peripherals from the PC. Reconnecting them, I inadvertently plugged the old external HDD into a USB3 port. Only later did I discover the invalid argument problem had gone away, but it no longer mattered because I had already moved all the files I wanted to other drives. Dec 4, 2016 at 8:58

Hade the same issue. For me the solution was to remove a line in /etc/samba/smb.conf

Had a line:

client max protocol = NT1

Removed this line and now it worked. It worked immediately, no restart or anything.


  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 24 at 11:07

Try restart windows... I don't now why but when I input (to map network disk) correct pass I have "Unable to access". After some many restart is it work all correctly :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.