0

So I haven't seen anything like this on the forum yet... if I'm mistaken please set me straight.

I have Ubuntu 14.04 and Mint 17 on separate partitions of the same hard drive, along with another backup hard drive on a HP Envy Dv7. Today I restarted my computer, and the computer didn't load the GRUB, or anything. In fact it was a black screen that reads, "Please install an operating system on your computer."

Thinking that the entire computer just crashed on me, I plugged in my live usb to see what information I could salvage from the computer and all the information is still on both partitions and the secondary drive.

I reinstalled Ubuntu just to see if that would solve the issue, but it did not. I still get the same error.

Any thoughts?

1

I would try boot-repair tool. You can install it during Your live USB session or by creating boot-repair live CD or USB and boot from it. You can find it there: http://sourceforge.net/p/boot-repair/home/Home/ .

  • So I created a boot-repair tool live usb on my friends computer, but when I plugged it in and started my computer it says that the selected boot image did not authenticate. Press enter to continue... when I press enter it turns the computer off. What am I doing wrong? – Dan Stinnett Jan 17 '15 at 0:36
  • You can try disabling 'secure boot' and enable 'legacy boot' mode in BIOS. – kcpr Jan 17 '15 at 0:47
  • Alright, I figured out my problem with the boot-repair tool usb... got it to boot up in the repair tool's session, ran through the whole process and am still getting the same error. When I disabled secure boot and enabled legacy boot it brought me back to the original error screen: Boot Device Not Found Please install an operating system on your hard disk Hard Disk (3F0) – Dan Stinnett Jan 18 '15 at 1:32
0

So... not sure exactly what I deleted, but I think I deleted a partition accidentally that linux needed to operate. I attached both hard drives to a different computer, formatted them both to FAT32 and reinstalled Mint through a live session. Now Mint seems to work pretty well.

Only strange part that I don't understand is why the Grub still thinks that Ubuntu 14.04 is on the system. Depending on which hard drive I boot from, it will freeze once the OS is up and running. Any thoughts?

  • The second paragraph is a legitimate question in its own right, I think. Unfortunately that question is off topic because questions about Linux Mint are off topic here, but you could try asking it on Unix & Linux Q&A. – karel Jan 18 '15 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.