4

These are the errors i am facing. I have tried gparted and disks.

Gparted error:

Input/output error during write on /dev/sdc

Error formatting volume

Error wiping device: Command-line `wipefs -a "/dev/sdc1"' exited with non-zero exit status 1: wipefs: error: /dev/sdc1: probing initialization failed: Device or resource busy
 (udisks-error-quark, 0)

Unable to access “6.2 GB Volume”

Error mounting /dev/sdc1 at /media/s/e1564750-3802-4dbb-8df8-d1bdff3f6a93:
Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdc1" "/media/s/e1564750-3802-4dbb-8df8-d1bdff3f6a93"' exited with non-zero exit status 32: mount: 
wrong fs type, bad option, bad superblock on /dev/sdc1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so.
1

1 Answer 1

7

It sounds like you may have a broken pendrive; go to a terminal and try these commands; ensure the pendrive is in fact /dev/sdc 1st though (use mount):

sudo -i
fdisk /dev/sdc
p # Lists the partitions
d # This deletes the partition. Again, be careful you have the right one!
p # check...
n # Create a new partition
b # This one isn't a command, it's a type selection - vfat
w # Save changes

This should give you a list of partitions; delete the only one there (if more, repeat 'd' until there aren't - whilst being careful that this is definitely the right drive! It should then create a new one, set it to FAT32, and write it.

If that works, type fdisk -t vfat /dev/sdc1 ; exit & you're done.

If not, try cat /dev/zero >/dev/sdc & let it run for a while (-c when bored..) - if it generates no errors, try step 1 again. If you still get I/O errors, it's damaged.

5
  • This is correct, but I think you should comment what each fdisk command is doing and the expected results. If the OP get something wrong it can trash the system...
    – Rmano
    Jan 16, 2015 at 9:15
  • That's what the following paragraph is? p=list, d=delete, etc.. there are two warnings in the answer about getting the right drive; & it's not going to be easy to trash the system if it IS the right drive.... I could do it as comments line-by-line, by I always find that distracts from the flow. Jan 16, 2015 at 9:35
  • 1
    I got b: unknown command then Re-reading the partition table failed.: Device or resource busy Jan 22, 2017 at 17:41
  • b isn't a command, it's the 'vfat' partitoin type - n command should've given you options Jan 26, 2017 at 10:32
  • @NicolasRaoul same here, but I did delete partition (d), then write (w), then tried GUI to format it as fat and it was successful
    – Developia
    Nov 19, 2017 at 11:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .