0

Environment:
toshiba chromebook with crouton ubuntu 12.04

Problem: Flash doesn't function on Chromium. Flash doesn't function on Firefox. Sound muted in Ubnutu Desktop.

I'm going to order the following by month, to make the events more clear.

November 2014

  • fresh install ubuntu 12.04;
  • desktop sound icon has full bars (top right icon near the time and sys settings icon)
  • Firefox didn't work with flash.
  • Switched to chromium, flash worked. (flash should be packaged w/chromium)

December 2014

January 2015

  • I navigated to chrome://plugins - no flash plugin listed
  • On youtube.com page had broken flash image.

steps taken:

  • Installed pepper as recommended on other sites, now flash pages (youtube) are 404 completely;
  • Uninstalled chromium, reinstall chromium, reinstall pepper
  • result == flash still doesn't function
  • sound on desktop is muted/disabled

Then I tried this solution from AskUbuntu , which unfortunately didn't help.

FIREFOX

  • with fresh install: youtube (flash) pages go grey then freeze. Results in "Adobe plug in error."

action: I attempted to install pepper.

result: "failed to load libpepflashplayer.so"

Help please!

  • Could you please rewrite the question to a more succinct and sober style? The style of writing would be nice in a different context, but here, it's hard to read this way (Note many here are none-native English speakers) – Volker Siegel Jan 15 '15 at 23:46
  • yes of course! Sorry about that. I've rewritten the request for help. – Christina Mitchell Jan 16 '15 at 0:03
  • Thanks, much better! I added some spaces to make the layout of your lists work (Needs empty line before; Newline needs two spaces on end of line - see help) – Volker Siegel Jan 16 '15 at 0:13
  • Oh, but you could still make the question more clear - in the title, and also in the text; You list a history of problems and solutions - but what's the one question here? If it's multiple questions, ask them separate. – Volker Siegel Jan 16 '15 at 0:16
  • I'll clarify in the title, but I do think the sound/flash issues are intertwined ;) – Christina Mitchell Jan 16 '15 at 0:16
0

I decided to try an install 14.04 again. I tried upgrade, then fresh install via crouton. Read a few snippets, found that 14.04 was not recommended for my chromebook.

Wiped and fresh install of 12.04 with chromium...sound works. Even after adding JRE & Eclipse. (which may have been the problem with prior versions)

Thanks for the pointers for this n00b. Much appreciated.

  • sure! I just posted to help other people in the same situation. (I'm not sure how to accept answer either.) – Christina Mitchell Jan 17 '15 at 18:31
-2

Note that adobe does not develop flash player for Linux http://get.adobe.com/flashplayer/ .

Thus, Your only way is to get pepper.

I suggest you getting it with Ubuntu package managers. This way updates will be installed automatically. As a side bonus, for software to get into official Ubuntu repository (kind off online directory from which software is downloaded) it must go through extensive testing, minimizing bugs.

Command line way:

  1. Open terminal
    Press ctrl+alt+T
  2. Locate the package needed
    Type sudo apt-cache search pepper | grep plugin
    You will be prompted for your password. There will be no indication, that you are typing something. Just type it and press Enter
    Command breakdown:
    • sudo gives you administrative rights
    • apt-cache search pepper searches for data about package having pepper in its name.
    • | pass previous command output to next as argument
    • grep plugin filter out all lines not having plugin
  3. Download the package needed
    Type sudo apt-get install pepperflashplugin-nonfree The nonfree indication means that the code is not publicly available, ie, the software is only free as in free beer, not as in free speech.
  4. Profit

Gui way (sorry, I'm too lazy to take pictures):

  1. Open Launcher
    Press super key, also known as Windows key.
  2. Open Ubuntu Software Center
    Typing Software and pressing Entershould be enough
  3. Find the package Type pepper and look for the package that seems the one you need
  4. Click install button
  5. Profit

Links for further reading:
https://en.wikipedia.org/wiki/Package_manager
http://www.linuceum.com/Desktop/linuxAppRepos.php
Note that you should not add new repositories, unless you know what you are doing.
https://en.wikipedia.org/wiki/Advanced_Packaging_Tool

  • 1
    step 2 :@localhost:~$ sudo apt-cache search pepper | grep plugin freshplayerplugin - PPAPI-host NPAPI-plugin adapter pepflashplugin-installer - Adobe/Google Pepper Flash Player plugin installer – Christina Mitchell Jan 16 '15 at 0:38
  • step 3: (precise)@localhost:~$ sudo apt-get install pepperflashplugin-nonfree Reading package lists... Done Building dependency tree Reading state information... Done Package pepperflashplugin-nonfree is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'pepperflashplugin-nonfree' has no installation candidate – Christina Mitchell Jan 16 '15 at 0:43
  • Thanks for both of your suggestions....also, option #2 GUI- it's unavail in software center for me. – Christina Mitchell Jan 16 '15 at 0:46
  • Open Ubuntu software center. Go to Edit -> Software Sources. Is multiverse ticked? – julka Jan 16 '15 at 0:49
  • yes multiverse is checked – Christina Mitchell Jan 16 '15 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.