0

I can't fix the problem that happened when I have upgraded from Ubuntu 12.04 to 14.04.1 (apt-get dist-upgrade). I'm becoming crazy.

Copy from log:

>Start-Date: 2014-12-17  18:39:01 
>Commandline: apt-get dist-upgrade 
>Install: [..] libboost-graph-dev:amd64 (1.48.0.2), klogd:amd64 (1.5-6ubuntu1)
>Error: Sub-process /usr/bin/dpkg returned an error code (1)
>End-Date: 2014-12-17  18:40:19


Start-Date: 2014-12-17  18:41:51
Commandline: apt-get -f install
Upgrade: glib-networking-common:amd64 (2.32.1-1ubuntu2, 2.40.0-1), gvfs-common:amd64 (1.12.1-0ubuntu1.2, 1.20.1-1ubuntu1), libc6-dev:amd64 (2.15-0ubuntu15~ppa1, 2.19-0ubuntu6.4), gvfs:i386 (1.12.1-0ubuntu1.2, 1.20.1-1ubuntu1), libc-dev-bin:amd64 (2.15-0ubuntu15~ppa1, 2.19-0ubuntu6.4), glib-networking-services:amd64 (2.32.1-1ubuntu2, 2.40.0-1), libc6:amd64 (2.15-0ubuntu15~ppa1, 2.19-0ubuntu6.4), libc6:i386 (2.15-0ubuntu15~ppa1, 2.19-0ubuntu6.4), gvfs-daemons:amd64 (1.12.1-0ubuntu1.2, 1.20.1-1ubuntu1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2014-12-17  18:41:55

Actually I can not upgrade or install or remove without have these errors:

~# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 glib-networking:i386 : Depends: glib-networking-services:i386 (>= 2.40.0-1)
                    Depends: glib-networking-common:i386 (= 2.40.0-1)
 gvfs:i386 : Depends: gvfs-libs:i386 (= 1.12.1-0ubuntu1.2) but 1.20.1-1ubuntu1 is installed
 gvfs-daemons : Depends: gvfs-libs (= 1.12.1-0ubuntu1.2) but 1.20.1-1ubuntu1 is installed
            Recommends: policykit-1-gnome but it is not installed
            Recommends: gvfs but it is not installed
 gvfs-libs : Depends: gvfs-common (= 1.20.1-1ubuntu1) but 1.12.1-0ubuntu1.2 is installed
 gvfs-libs:i386 : Depends: gvfs-common:i386 (= 1.20.1-1ubuntu1)
 libc-dev-bin : Depends: libc6 (> 2.19) but 2.15-0ubuntu15~ppa1 is installed
 libc6-dev : Depends: libc6 (= 2.19-0ubuntu6.4) but 2.15-0ubuntu15~ppa1 is installed
 libglib2.0-0 : Depends: libc6 (>= 2.17) but 2.15-0ubuntu15~ppa1 is installed
 libglib2.0-0:i386 : Depends: libc6:i386 (>= 2.17) but 2.15-0ubuntu15~ppa1 is installed
 libudev1 : Depends: libc6 (>= 2.17) but 2.15-0ubuntu15~ppa1 is installed
 libudev1:i386 : Depends: libc6:i386 (>= 2.17) but 2.15-0ubuntu15~ppa1 is installed
E: Unmet dependencies. Try using -f.

Adding -f, these are the only differences from the previous error:

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I had found that there were the older PPA and I updated it:

deb http://it.archive.ubuntu.com/ubuntu/ utopic main
deb-src http://it.archive.ubuntu.com/ubuntu/ utopic main

deb http://security.ubuntu.com/ubuntu utopic-security main
deb-src http://security.ubuntu.com/ubuntu utopic-security main

#deb http://it.archive.ubuntu.com/ubuntu/ utopic-updates main universe restricted multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ utopic-updates main universe restricted multiverse

So I used the following command for each packet that was generating an error according to dpkg --configure -a:

echo "libc6-dev hold" | dpkg --set-selections

and this is the result:

# dpkg --get-selections | grep hold
desktop-file-utils                              hold
glib-networking:i386                            hold
gvfs-libs                                       hold
gvfs-libs:i386                                  hold
libc-dev-bin                                    hold
libc6-dev                                       hold
libgcrypt11-dev                                 hold
libglib2.0-0                                    hold
libglib2.0-0:i386                               hold
libglib2.0-bin                                  hold
libglib2.0-dev                                  hold
libgnutls-dev                                   hold
libpcre3-dev                                    hold
libpolkit-agent-1-0                             hold
libpolkit-gobject-1-0                           hold
libsecret-1-0                                   hold
libsecret-1-0:i386                              hold
libudev1                                        hold
libudev1:i386                                   hold
libudisks2-0                                    hold
udisks2                                         hold

But, again, I have the some problems with upgrade, install and remove. This is the only "strange" output that I have found:

# apt-get remove libc6-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 build-essential : Depends: libc6-dev but it is not going to be installed or
                            libc-dev
 comerr-dev : Depends: libc6-dev but it is not going to be installed or
                       libc-dev
 e2fslibs-dev : Depends: libc6-dev but it is not going to be installed or
                         libc-dev
 glib-networking:i386 : Depends: glib-networking-services:i386 (>= 2.40.0-1)
                        Depends: glib-networking-common:i386 (= 2.40.0-1)
 gvfs:i386 : Depends: gvfs-libs:i386 (= 1.12.1-0ubuntu1.2) but 1.20.1-1ubuntu1 is to be installed
 gvfs-daemons : Depends: gvfs-libs (= 1.12.1-0ubuntu1.2) but 1.20.1-1ubuntu1 is to be installed
                Recommends: policykit-1-gnome but it is not going to be installed
                Recommends: gvfs but it is not going to be installed
 gvfs-libs : Depends: gvfs-common (= 1.20.1-1ubuntu1) but 1.12.1-0ubuntu1.2 is to be installed
 gvfs-libs:i386 : Depends: gvfs-common:i386 (= 1.20.1-1ubuntu1)
 libblkid-dev : Depends: libc6-dev but it is not going to be installed or
                         libc-dev
 libbz2-dev : Depends: libc6-dev but it is not going to be installed or
                       libc-dev
 libc-dev-bin : Depends: libc6 (> 2.19) but 2.15-0ubuntu15~ppa1 is to be installed
 libcurl4-gnutls-dev : Depends: libc6-dev but it is not going to be installed or
                                libc-dev
 libexif-dev : Depends: libc6-dev but it is not going to be installed
 libexpat1-dev : Depends: libc6-dev but it is not going to be installed or
                          libc-dev
 libfreetype6-dev : Depends: libc6-dev but it is not going to be installed or
                             libc-dev
 libgcrypt11-dev : Depends: libc6-dev but it is not going to be installed or
                            libc-dev
 libglib2.0-0 : Depends: libc6 (>= 2.17) but 2.15-0ubuntu15~ppa1 is to be installed
 libglib2.0-0:i386 : Depends: libc6:i386 (>= 2.17) but 2.15-0ubuntu15~ppa1 is to be installed
 libgnutls-dev : Depends: libc6-dev but it is not going to be installed or
                          libc-dev
 libicu-dev : Depends: libc6-dev but it is not going to be installed or
                       libc-dev
 libjpeg-turbo8-dev : Depends: libc-dev
 libpcre3-dev : Depends: libc6-dev but it is not going to be installed
 libsasl2-dev : Depends: libc6-dev but it is not going to be installed
 libstdc++6-4.6-dev : Depends: libc6-dev (>= 2.13-0ubuntu6) but it is not going to be installed
 libtiff4-dev : Depends: libc6-dev but it is not going to be installed or
                         libc-dev
 libtool : Depends: libc6-dev but it is not going to be installed or
                    libc-dev
 libudev1 : Depends: libc6 (>= 2.17) but 2.15-0ubuntu15~ppa1 is to be installed
 libudev1:i386 : Depends: libc6:i386 (>= 2.17) but 2.15-0ubuntu15~ppa1 is to be installed
 libxft-dev : Depends: libc6-dev but it is not going to be installed or
                       libc-dev
 uuid-dev : Depends: libc6-dev but it is not going to be installed or
                     libc-dev
 zlib1g-dev : Depends: libc6-dev but it is not going to be installed or
                       libc-dev
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I hope that some one can help me, I don't want to format :/ Cheers

1

You seem to have libc6, udev etc from ppas. Do you? These are just too fundamental for coming from outside ubuntu.

I expect you will have to get rid of these ppas [from sources.list etc] and try again

  • I have just edited to talk about source list but there were only precise PPA: deb it.archive.ubuntu.com/ubuntu utopic main deb-src it.archive.ubuntu.com/ubuntu utopic main deb security.ubuntu.com/ubuntu utopic-security main deb-src security.ubuntu.com/ubuntu precise-security main #deb it.archive.ubuntu.com/ubuntu precise-updates main universe restricted multiverse #deb-src it.archive.ubuntu.com/ubuntu precise-updates main universe restricted multiverse – Mirko Torrisi Jan 15 '15 at 18:31
  • Now unhold all your packages [See askubuntu.com/questions/164587/… ]. apt-get update. Remove the packages and dependencies that came from ppa and try upgrading again – Rusi Jan 15 '15 at 18:42
  • I should add here that by 'remove' I mean the package you've installed from ppa and immediate dependencies. eg if you've installed foo then say foo and libfoo. Dont remove fundamental things like libc6 udev etc, or ur machine will be borked! – Rusi Jan 15 '15 at 19:24
  • I did not install anything after that I lunched apt-get dist-upgrade so I do not know what I have to do after that I have unholded all my package and lunched apt-get update. Thanks for your help, it is very appreciated! – Mirko Torrisi Jan 15 '15 at 22:44
  • <1> Cleanup not just sources.list but also everything under dir sources.list.d. <2> update <3> Find 'local/obsolete' packages... ie <3a> [In synaptic] click status and then local/obsolete OR <3b> command-line $sudo aptitude search ~o <4> One by one remove those and try upgrading the rest packages individually (from your original error message) before trying dist-upgrade – Rusi Jan 16 '15 at 2:28
0

have you tried to

  • clear the apt cache apt-get clean
  • clear the error messages
  • edit your sources list file. vi /etc/apt/sources.list

After the source list file has been changed run

apt-get update 

then try to upgrade/install packages

  • Welcome to askubuntu! Answers are more helpful if they include the how as well as the what. – Elder Geek Jan 15 '15 at 21:47
  • @Evan I cleaned apt-get but I do not know what do you mean about "clear the error and then edit your sources list". Anyway I have edited sources.list, now there are only the default (six) PPA. – Mirko Torrisi Jan 15 '15 at 22:40
0

One more thing to try is to upgrade the conflicting core packages. That is try

$ sudo apt-get upgrade libc6 libc6-dev libc-dev udev

This will likely give you a list of packages that this will remove. Its important that this list contains packages that came from ppas and not core packages like the above

[BTW It will help if you have synaptic and/or aptitude installed. If not dunno how to install now in a broken state :-( ]

Update

Just discovered here that you could try this awk command to list your obsolete/local packages

awk '/^Package: / {print $2}' /var/lib/dpkg/status | sort |
(awk '/^Package: / {print $2}' /var/lib/apt/lists/*_Packages | sort |
 comm -23 --nocheck-order /dev/fd/3 -) 3<&0 

The list you get from that is probably the offending package list

  • I have not synaptic or aptitude but with # apt-get -f upgrade libc6 libc6-dev libc-dev udev I obtained some shy results pastebin.com/SbML5MUu Same result also with upgrade or install or autoremove. – Mirko Torrisi Jan 16 '15 at 12:49
  • or dist-upgrade (all with -f option). – Mirko Torrisi Jan 16 '15 at 13:00
  • Running out of steam and ideas :-(. There should be NO ppas in sources.list -- can you pastebin your sources.list? ANother thing you can try is to downgrade your sources.list again to the previous (12.4) version and try again – Rusi Jan 16 '15 at 13:59
  • pastebin.com/53K13eai :-( – Mirko Torrisi Jan 16 '15 at 14:10
  • Cant see anything obvious to be corrected :-( So now Im left with the last (tedious) suggestion: Restore sources back to 'precise' ie 12.4 and try update again – Rusi Jan 16 '15 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.