3

I have several computers running xubuntu; my main PC does accented chars which is documented, an old 32-but Asus EEE produces a back-tick as it should, but my 64-bit EEE immediately closes the current tab in Terminal (specifically, xfce4-terminal) when I press the key. It doesn't close an untabbed Terminal.

Shift-backtick gets me a '¬' character, ctrl & alt modifiers do nothing, but just touching the key alone (or with Fn) closes my terminal. I've tried it with the 105-key Int'l layout, with the Asus-laptop layout; there are no compose settings, setxkbmap says "rules: evdev, model: asus_laptop, layout: gb" which is as it should be.

This behaviour has survived a long time & a lot of updates - possibly even a reinstall (retained /home/), although I wouldn't swear to that.

There are no logs created (that I can see) when this happens, and it doesn't append the current history to ~/.bash_history.

Any ideas what this is doing, and how I can persuade it not to?

6
  • Press Ctrl-V, then press the backtick key. What happens? – muru Jan 15 '15 at 12:57
  • Nothing - it fails to close it. The first time you try. Then, it's back to usual! – Mark Williams Jan 15 '15 at 13:09
  • Ctrl-V is verbatim mode - instead of allowing the terminal to interpret the next character, it shows what would be sent instead (for example, Ctrl-V Ctrl-C should show ^C). Does it really show nothing when you do Ctrl-V`? – muru Jan 15 '15 at 13:13
  • The first time I tried, it did literally nothing. I tried a plain ` & sure enough, closed. I then opened a new tab, tried the same trick - closed. It now does that every time! I also tried a new terminal, where CTRL-V+` got me a ` in the terminal! Experiment reveals that if I have a tab open, it closes; if I'm down to just the plain untabbed-terminal, it types ` - I hadn't noticed that before. – Mark Williams Jan 15 '15 at 13:19
  • Perhaps worth noting, it doesn't save command history & is set to UTF-8 encoding – Mark Williams Jan 15 '15 at 13:23
2
+50

UPDATE::A Couple things to try :

Let me just make sure, you are Using the Great Britan (GB) Key-map on purpose, as opposed to the US english keyboard layout? What is your preferred language?

In any event, I suspect your language settings are the cause.

You could do $loadkeys en_us to load the usa English keymap, or $loadkeys gb if you want Great Britain instead. you should also have a looks at your language settings, to see if they are consistent with your key map settings. Goto settings>language and set your language to your locality.

if that doesnt work, do this:

open up xcfe4 terminal and do $set -vx

then: $who youll get something like:

~$ who
j0h     :0           2015-03-27 09:25 (:0)
j0h     pts/4        2015-03-27 09:43 (:0.0)

note the terminal you are in pts/4 or something like that. then, open up and other terminal. you might try xfce-terminal, or something else. Give your current terminal to this command in the other terminal window

$cat < /dev/pts/4 

this window is now listening to the first terminal. go to the first terminal and hit enter then type the backtick what does the second terminal show? is it an IO error?

//Original Questions below

This would be a comment, but I want to give an example, and ask some questions.

1.What kind of keyboard is it? Is the keyboard programmable, 
  like macros and such?
2.Press ctrl+alt+F2 and login. what happens in an actual shell 
  vs the terminal emulator?
3. type the command:$xev and press back tick. what happens?

heres what i get:

$xev
KeyRelease event, serial 36, synthetic NO, window 0x3a00001,
    root 0x28d, subw 0x0, time 156854516, (885,629), root:(888,682),
    state 0x0, keycode 49 (keysym 0x60, grave), same_screen YES,
    XLookupString gives 1 bytes: (60) "`"
    XFilterEvent returns: False

what does your XLookupString say?

4.if you paste in back-ticks, does the command execute? or exit?  
what happens whe you run: echo $(`echo date`) ?


5. what is the output of bind -p | grep \`
 
3
  • It's a standard eee notebook keyboard, no 'funny' setup of which I am aware. – Mark Williams Mar 26 '15 at 23:06
  • It's a bog-standard eee notebook keyboard, no macros of which I am aware. In a real shell I have proper behaviour, in xfce-terminal I don't. I have added xev's response above. I'm unsure where to find the XLookupString, for now; pasted `'s are OK and I can run echo $(`echo date`) IF I paste in the ticks (getting the date). Bind -p | grep [pasted tick] says "`": self-insert, but I can't type it in directly, of course. – Mark Williams Mar 26 '15 at 23:20
  • xterm also works properly (but didn't offer tabs anyway), if that's any help. – Mark Williams Mar 26 '15 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.