3

My (Symfony) application currently crashes, throwing the error:

("The Symfony\Component\Intl\Collator\Collator::__construct() method's argument $locale value 'fr' behavior is not implemented. Only the locale "en" is supported. Please install the "intl" extension for full localization capabilities.")

I actually didn't have intl installed, so I did

sudo apt-get install php5-intl

That also got libicu52 dependency in the process
My application still complains with the same error
I restarted my web server (NginX with php-fpm) manually (even if apt-get does it already).

How can I find the origin of the issue ?

4
  • Does this help? There is a line in app/config/config.yml to be changed. – Jos Jan 15 '15 at 12:04
  • The question is pretty much the same but a default installation already contains the default_locale parameter set in app/config/config.yml – Pierre de LESPINAY Jan 17 '15 at 6:14
  • @PierredeLESPINAY did you found a fix for this? I'm having the exact same problem. (thank you) – JoséMi May 21 '15 at 5:53
  • Well nope, thx for the vote up – Pierre de LESPINAY May 21 '15 at 9:31
0

try this if original solution does not work for you: By default, symfony2 is able to manage the "en" extension but to get other language, you have to install the php-intl extension.

The easiest option is to install it with the composer, because it expose global variable for you ... etc

All of this is explained here symfony/components/intl.

For the composer extension installation it's symfony/components/using_components.

So after eading this, you need to execute :

composer require symfony/intl

DO NOT FORGET TO RESTART YOUR APACHE2 SERVER (sudo service apache2 restart)

source: https://stackoverflow.com/questions/25723804/a-php-platform-install-ask-me-intl-extension-but-it-seems-already-installed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.