0

Hi folks (and thanks in advance for reading this),

I'm currently trying to implement a delay function into an exim4 mta. It is running in the hand-on-to-smarthost mode. I'd like to add a delay to every e-mail that is handed to the mta locally before it is forwarded onto the internet.

What I've tried: I've added "delay = 20s" to the final "accept" statements in the acl-files that rest in /etc/exim4/conf.d/acl . Usually that should do, but unfortunately I can't see any change.

First of all, if I log onto the mailserver using telnet, there should be a delay, but there's nothing.

Any help is appreciated!

Thank you for your efforts in advance!

Stephan

0

If I understand you, you wish to receive mail on server, then hold mail in queue, do something and send after that to smarthost. Ok

Delay can not be applied in communication client <-> mta because you will got time_out. My suggestion is to use queue_domains or queue_smtp_domains and hold_domains.

SMTP communication aka telnet on server on port 25 will go normally, server will get mail, store them in queue, hold xyz sec, send them to smarthost.

More information about Exim main configuratin you can find here

  • Thank you for your suggestion. Unfortunately, I'm a bit of a newby with exim. I'm running exim over /etc/init.d/exim4 and it's configured mostly over dpkg-reconfigure exim4-config (just the tls-settings were done manually). Could you just tell me how to implement queue_smtp_domain / queue_domain / hold_domain ? I haven't found anything in the main config documentation. Thank you! – Stephan_1975 Jan 19 '15 at 7:03
  • Try with this link. Also you have example of code here – 2707974 Jan 19 '15 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.