2

i just bought an asus laptop. I installed Kubuntu 14.10 alongside windows 8.1. When I'm trying to configure it on system settings it's said "Synaptics driver is not installed (or not in use)". With windows the touchpad works fine, with kubuntu the scrolling and other settings don't work. I tried installing Synaptics driver, but it still doesn't work. How can I fix it? Thank you very much.

  • cat /proc/bus/input/devices from a terminal, does your device show up? – geoffmcc Jan 14 '15 at 22:49
  • I think this is it: I: Bus=0011 Vendor=0002 Product=0001 Version=0063 N: Name="PS/2 Logitech Wheel Mouse" P: Phys=isa0060/serio4/input0 – Chiara Jan 16 '15 at 10:04
0

Here is the repository you'll find the packages mentioned by @TrungTa. This is a more persistent way to share the package than via dropbox. More, we got last updates ;-)

0

I think your laptop may have a FocalTech touchpad. This happens to me as well as I have an Asus UX303LN.

The reason is that current Linux kernel does not support FocalTech touchpad. You can see more detail here.

Currently, I'm using a patched kernel, which resolve this problem. But hoping the official kernel will be released soon.

  • Thank you for your answer! I tried to install that patch but it says that it interferes with another package "linux-signed-image-3.16.0-28-generic". – Chiara Jan 16 '15 at 9:59
  • Which is the model of your Asus? Can you check this list to see if the patched kernel work with your laptop? https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1372609/comments/165. I also met some kind of messages when installing the patched kernel. (I can't remember exactly). What I did was that exacting the compressed file, entering the suitable kernel version (for you, it should be 3.16.0-28...), and running "sudo dpkg -i *.deb". Can you also check with the bug discussion above to see if it can help? – Trung Ta Jan 16 '15 at 15:37
0

I've Kubuntu 15.04. Suddenly touchpad stopped working and I got the same error in system settings. What worked for me is to remove Synaptics driver, install it then restart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.