I installed 11.0`4 via wubi on my new Acer Aspire 7551G-7606. When I boot it up it cannot detect wifi. As a matter of fact, the "Enable Wifi" checkbox in the dropdown is disabled and when I enable it I cannot see any wifi networks even though they are there (I'm on one right now)

When I run through the System Testing app the first time "Detecting your network controller(s)" worked fine but "testing your connection to the internet" resulted in an error. Stepping back and then forward again and even restarting my system and re-running the system testing app results in "detecting your network controller" coming up empty.

I've installed via wubi several times including to a very similar Acer Aspire 7740-5691 and never had any problems whatsoever. Everything works great in windows, according to windows devices I have an atheros ar5b97.

As per the comment I ran lspci which reports Network controller: Atheros Communications INc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

sudo lshw -class network recognizes it as

 *-network DISABLED
   description: Wireless interface
   product: AR9287 Wireless Network Adapter (PCI-Express)
   vendor: Atheros Communications INc.
   physical id: 0
   bus info: pci@0000:06:00.0
   logical name: wlan0
   version: 01
   serial: the-number
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list enternet physical wireless
   configureation: broadcast=yes driver=ath9k driverversion=2.6.38-8-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq: 17 memory:d0200000-d020ffff

rfkill list

0: acer-wireless: Wireless LAN
  Soft blocked: yes
  Hard blocked: no
1: phy0: Wirless LAN
  Soft blocked: no
  Hard blocked: no

What would my next step be in trying to fix this issue?

  • 1
    suggest run lspci and or lsusb to find out your wifi hardware - and then run sudo lshw -class network to see how your kernel recognises your network devices – fossfreedom Aug 16 '11 at 19:16
  • @fossfreedom - see edit – George Mauer Aug 16 '11 at 19:32
  • 1
    interesting - how about rfkill list – fossfreedom Aug 16 '11 at 19:37
  • @fossfreedom see again - I just read the man and tried rfkill unblock 0 and nothing changed – George Mauer Aug 16 '11 at 19:42

Try blacklisting the acer-wmi kernel module:

sudo nano /etc/modprobe.d/blacklist.conf

add blacklist acer_wmi as a new line at the bottom of this file.

then reboot.


The acer-wmi kernel module enables you to control the following:

  • the wireless LAN card radio
  • inbuilt Bluetooth adapter
  • inbuilt 3G card
  • mail LED of your laptop
  • brightness of the LCD panel

With regards to wireless, all acer-wmi does is enable the radio on the card. It is not responsible for the wireless LED - once the radio is enabled, this is down to the wireless driver for your card.

However for some acer laptop models - there is a conflict between the Acer firmware and the kernel implementation. This is why you need to blacklist.


| improve this answer | |
  • Yowza that worked! Now what the heck did I just do? – George Mauer Aug 16 '11 at 20:25
  • updated - hope this (and the link) answers all! – fossfreedom Aug 16 '11 at 20:32

If blacklisting the acer_wmi driver doesn't work (which it didn't for me, nor did the nohwcrypt=1 trick), you can try updating the kernel to 3.6: Artheros AR9287 Txpower

That worked for me, when nothing else did. I hope others who have the same stubborn problem will be able to resolve it in this way.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.