1

When trying to install skype using aptitude I get the following error :

The following NEW packages will be installed:
libaudio2:i386{a} libavahi-client3:i386{a} libavahi-common-data:i386{a} 
libavahi-common3:i386{a} libcgmanager0:i386{a} libcups2:i386{a} 
libdbusmenu-qt2:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} 
libdrm-radeon1:i386{a} libelf1:i386{a} libexpat1:i386{a} libffi6:i386{a} 
libfontconfig1:i386{ab} libgcrypt11:i386{a} libgl1-mesa-dri:i386{ab} 
libgl1-mesa-glx:i386{ab} libglapi-mesa:i386{ab} libglib2.0-0:i386{a} 
libgnutls26:i386{a} libgpg-error0:i386{a} libgssapi-krb5-2:i386{a} 
libgstreamer-plugins-base1.0-0:i386{ab} libgstreamer1.0-0:i386{ab} 
libice6:i386{a} libjbig0:i386{a} libjpeg-turbo8:i386{a} libjpeg8:i386{a} 
libllvm3.4:i386{a} libmysqlclient18:i386{a} liborc-0.4-0:i386{a} 
libp11-kit0:i386{a} libpciaccess0:i386{a} libqt4-dbus:i386{a} 
libqt4-declarative:i386{a} libqt4-network:i386{a} libqt4-opengl:i386{a} 
libqt4-script:i386{a} libqt4-sql:i386{a} libqt4-sql-mysql:i386{a} 
libqt4-xml:i386{a} libqt4-xmlpatterns:i386{a} libqtcore4:i386{a} 
libqtdbus4:i386{a} libqtgui4:i386{a} libqtwebkit4:i386{a} 
libselinux1:i386{ab} libsm6:i386{a} libsqlite3-0:i386{a} 
libssl1.0.0:i386{a} libtasn1-6:i386{a} libtiff5:i386{a} 
libtxc-dxtn-s2tc0:i386{a} libudev1:i386{ab} libuuid1:i386{ab} 
libx11-6:i386{a} libx11-xcb1:i386{a} libxcb-dri2-0:i386{a} 
libxcb-dri3-0:i386{a} libxcb-glx0:i386{a} libxcb-present0:i386{a} 
libxcb-sync1:i386{a} libxdamage1:i386{a} libxext6:i386{a} 
libxfixes3:i386{a} libxi6:i386{a} libxml2:i386{a} libxrender1:i386{a} 
libxshmfence1:i386{a} libxslt1.1:i386{a} libxss1:i386{a} libxt6:i386{a} 
libxv1:i386{a} libxxf86vm1:i386{a} mysql-common{a} skype 
skype-bin:i386{a} sni-qt:i386{a} 
0 packages upgraded, 78 newly installed, 0 to remove and 0 not upgraded.
Need to get 58.7 MB of archives. After unpacking 206 MB will be used.
The following packages have unmet dependencies:
libgstreamer-plugins-base1.0-0 : Breaks: libgstreamer-plugins-base1.0-0:i386 (!=  1.2.4-1~ubuntu1) but 1.2.3-1 is to be installed.
libgstreamer-plugins-base1.0-0:i386 : Breaks: libgstreamer-plugins-base1.0-0 (!= 1.2.3-1) but 1.2.4-1~ubuntu1 is installed.
libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 10.1.3-0ubuntu0.1) but 10.1.0-4ubuntu5 is to be installed.
libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 10.1.0-4ubuntu5) but 10.1.3-0ubuntu0.1 is installed.
libfontconfig1 : Breaks: libfontconfig1:i386 (!= 2.11.0-0ubuntu4.1) but 2.11.0-0ubuntu4 is to be installed.
libfontconfig1:i386 : Depends: fontconfig-config:i386 (= 2.11.0-0ubuntu4) which is a virtual package.
                   Breaks: libfontconfig1 (!= 2.11.0-0ubuntu4) but 2.11.0-0ubuntu4.1 is installed.

Tried with apt-get earlier which gives the following error

The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

Tried fixing with Synaptic Package Manager but the filter Broken Packages doesn't show any packages.

Tried

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get install -f

Tried adding the following in /etc/apt/preferences and sudo apt-get dist-upgrade then sudo apt-get install skype:

Package: *       
Pin: release a=quantal*
Pin-Priority: 2012

None of the above worked.

1
  • Is apt-get update completes successfully on your machine? Have you configured other pins? We have installed Skype on Ubuntu 14.04 without any issues - but sound stops working after a few minutes. Jan 14, 2015 at 7:57

1 Answer 1

1

Enabling Recommended Updates and Unsupported Updates in 'Software & Updates' and then installing skype worked.

It seems I didn't have the latest versions of some packages since I have disabled Recommended Updates and Unsupported Updates. I had only Security Updates enabled. I was thinking that I had the latest versions of packages but apparently I was only getting security updates.

1
  • Mark it as the answer.
    – Babbzzz
    Jan 14, 2015 at 10:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .