2

When I try to attach an external monitor to my laptop, the windows are stretched oddly horizontally and the click offset is off. The nvidia settings also doesn't seem to show the built-in laptop display, but the ubuntu display settings does.

If I add a third monitor, the two external monitors work fine with no stretching or misclicking, but the laptop monitor is blank. I can't drag windows to it but I can move the mouse there.

If I use any monitor by itself, it works fine.

This is a fresh (with the exception of crashplan) install of 14.04.1 LTS x86_64, using the latest tested driver in additional drivers (nvidia-331.113 and nvidia-prime). It's on a Dell M6800 with a Quadro K4100M. Displays are connected via display port from dock.

Since I can't post images, here is an album of screenshots:

http://imgur.com/a/MpL5w#0

update: purging nvidia drivers and using Nouveau works fine, but runs slow.

update: It is related to Nvidia Optimus. Turning that off in the BIOS fixes the issue, though I'd like to be able to switch to my integrated graphics in the future.

  • What was the version of nVidia drivers that you were running? – Fabby Jan 14 '15 at 22:41
  • nvidia-331 331.113-0ubuntu0.0.4 nvidia-prime 0.6.2 – eengineer Jan 16 '15 at 1:15
  • How technical are you? Do you know what a PPA is and what rolling software versions forward and rolling backward is? – Fabby Jan 16 '15 at 1:17
  • Decently technical, I've done those things before and would be willing to help, send logs, etc. Note that turning off Nvidia Optimus fixes this particular issue. – eengineer Jan 17 '15 at 0:52
  • First of all: never trust anyone telling you to install a PPA! (including me) PPAs are one of the few vectors to get malware on Linux and you should use your own personal judgement before moving ahead! That being said, PPA:Boris:RU_MOB with a few 100 users is to be reviewed with slightly more caution then PPA:webupd8.org wiht a few 10000 users. (see answer below) – Fabby Jan 17 '15 at 1:22
0

The standard Ubuntu NVidia drivers generate some problems on slightly older and slightly newer NVidia hardware.

If you want more then the standard Ubuntu repository drivers, install the xorg.edgers PPA.

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update

As the xorg.edgers group ask not to give installation instructions directly without linking to their page, this is the best I can do (for now).

If you don't know what a PPA is or need some guidance after reading their page, leave a comment below.

  • @eengineer: Do you know what rolling forwards and backwards of software is? – Fabby Jan 30 '15 at 8:52
  • Yes, though using xorg.edgers has a different set of problems: answers.launchpad.net/ubuntu/+source/… – eengineer Feb 26 '15 at 0:14
  • Wow! You're really having a problem... Did you try rolling back? Oh, and apparently the above did answer your question (though you have a different problem now) so as you're a reputation 1 user: If this did answer your question, don't forget to click the grey under the "0" at the left of this text, which means "yes, this answer is valid"! ;-) – Fabby Feb 26 '15 at 1:31
  • Rolling back replicates the old issues, but the boot hanging problem is still there and growing. I suppose this answer is somewhat valid, notwithstanding the other missing display and missing cuda device problem. – eengineer Feb 26 '15 at 15:48
  • There is something which you could still try and that is version 343. If you google around for nvidia-343_343.22-100ubuntu100~ppa1~trusty_amd64.deb you will still find one repository in the UK that has not deleted it yet. It used to cause kernel panics on some systems, (and that's why I'm not posting a link. You'll have to have read the entire conversation here to know the risks) but on some (newer) graphics cards it produced spectacular results. I would definitely make a system back-up before starting! – Fabby Feb 27 '15 at 9:02
4

Had the same problem on 16.04 and was finally able to solve it today.

According to NVIDIA, its because the built in display is connected to intel iGPU. https://devtalk.nvidia.com/default/topic/807239/nvidia-server-setting-utility-doesn-t-see-laptop-screen/

Which basically result in Nvidia x server has no control over your built in monitor.

To solve this, switch graphic mode from MShybrid to discrete in BIOS setting, which can force the built in monitor to be driven by you discrete GPU, and x server will works correctly to recognize both build in and external display.

1

I suffered from this problem. finally found this post: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1382462/comments/35

On CompizConfig Settings Manager, go to General Options, then Display Settings and do the following:

  • Uncheck Detect Outputs.
  • In the Outputs array, set the resolutions of each of your screens.

The numbers after the resolution "1920x1080+0+0" are the offset. It's important to add this offset according to your needs. I have two full HD screens, so I added the following configuration:

1920x1080+0+0
1920x1080+1920+0

The second output has an offset of 1920, because it is on the right side of the first output, which has a width of 1920.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.